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This booklet has been prepared by Andy Hawkins for students enrolled and studying the unit Author Interactive Sequences.
Thanks to Graeme Harris, Ryan Goggin, Adil Mistry, Todd Millias, Vince Valentini and Anthony Carriero for advice and input to this book. Special thanks go to Richard Lancaster for slaving away at the first iteration of this course handbook called Game Maker :  The Tutorials.  Some of the copy and the framework of that book has been the foundation of this updated reference.
Comments and corrections to:  
andy.hawkins@central.wa.edu.au
The purpose of this booklet is to introduce students to 2D game design and development using the Torque 2D program created by Garage Games LLC. Some of the tutorials are based on commercial coding techniques and software tools created by Andy Hawkins and grateful acknowledgement is made to both his software and his teaching material. 


Screen captures are from versions 1.7.5 of Torque 2D and reproduced with permission of the copyright owner, Garage Games LLC.


Cover art is SUPER Hero by Ryan Goggin.
Copyright © 2011 Central Institute of Technology. All rights reserved. No part of this may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, or by any information storage or retrieval system, without prior written permission from Central Institute of Technology.



Disclaimer: Every effort has been made to ensure this booklet is free from error or omissions. However, you should conduct your own enquiries and seek professional advice before relying on any fact, statement or matter contained in this book. Central Institute of Technology is not responsible for any injury, loss or damage as a result of material included or omitted from this booklet.
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[bookmark: _Toc310968337]Introduction.

Video games have been around for a long time.  Over the course of the history of video games we have seen quantum leaps in technology, but perhaps not so much with respect to game play.  Currently there are arguable 3 modes of delivery for game play at the moment.  Casual games, Core games, and MMO’s.  
[image: ]Casual games such as Angry Birds, Braid and Castle Crashers have brought back the classic Platformer game play of the 80’s. 
Core games such as Medal of Honour, Call of Duty and Battlefront have focused on what could be considered an elite group of gamers that like to play combat games against each other in realistic theatres of war.
MMO’s are an expansive subject, and games such as World or Warcraft and League of Legends have players focus on the seemingly monotonous tasks of grinding or continually repeating the same combat until they increase their level, promising more weapons, skills and new lands to explore.
While Torque 2D  can certainly make any of these genres, we will focus on the Casual Games market for this unit.
[bookmark: _Toc310968338]What to expect / Outcomes.
[image: sketch%20by%20Todd%20millias]
The formal game making process is a dark art, and a lot like a rollercoaster, of twists and turns, massive inclines and steep descents.  You will learn the process of making compelling 2D games from start to finish.  You will also learn about the history of computer games with respect to making compelling game play. You will learn the Torque Game Builder program, and along the way you will be introduced to other core game making skills such as project planning, asset creation, quality assurance and bug testing.
Enjoy the ride!

Character sketch in pencil by Todd Millias
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Torque 2D Pro 1.7.5 is an easy to use program for creating 2D computer games. It runs on the Windows and Macintosh operating systems and comes in two versions, PC and Mobile. The PC version exports to Web, Mac, Windows and Linux.  All the games in this book can be made using the PC version.
1. Prepare your hard drive first.  Make a folder called T2DSemester1.  Now make another folder inside that called Session1.
2. Next go to the Resources folder for this unit, locate Session1 and paste that into the T2DSemester1 folder. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.

[image: ]  
1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in BalloonPop (no spaces). Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session1.  So your final destination will be something like “E:/ T2DSemester1/Session1”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


There are several basic elements you can import into Torque 2D, behaviours, particles, 2d images, paths and 2d animation sequences.  The rest are handled in script.  
Script which is really a proprietary language called TorqueScript is similar in some ways to a professional language called C++.   Torque 2D can also be programmed using C++. 
 It can also almost be used to create games without writing a single line of code, so it’s artist friendly.  We want you to dig a little deeper than that.  
Even if you are a coder or an artist, you should learn to manage and practice skills in art and coding so that you become proficient at both.  
[bookmark: _Toc310968340]Copying behaviors.
4. Next you will need to copy the “behaviors” over to the program coding area.  Browse to your hard drive and under Session1 you will find this structure.  You need to copy the “behaviors” folder to the clip board, by right clicking on it and selecting “copy”.


5. Now go into the BalloonPop folder.  You will see this folder structure.  Click on the game folder circled.




6. You will now see this folder structure.  Press CTRL + V to paste the behaviors folder and confirm any changes to overwrite files already there.
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Great!  Now you are ready to work on the game.  Please note that this procedure of creating the game and then copying over the session files and behaviors will be standard from now on, and will be referred to in less detail in subsequent lessons.
You’ll need to reload the behaviors so click on the Project tab as shown and then click on Reload Project.
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As with all good game designers / creators we need to make a plan of attack.  The first step is always to write a short description of a new game:

A balloon floats around a room, wrapping around from top to bottom and left to right. Clicking on it will pop the balloon. Each popped balloon is worth 100 points.

[bookmark: _Toc310968343]Functional Specification.
This forms what’s know as a functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our balloon popping game, the functional spec is quite simple.
1. Show screen
2. Load in some balloons
3. Place some balloons on screen.
4. Give them movement behaviour.
5. Detect if the player clicks on them.
6. Pop balloons clicked on and add to score.
7. Generate some new balloons.
The game never really finishes.  It’s going to be a survival game.  We’ll add some higher valued balloons as well; by there will less of them.
[bookmark: _Toc310968344]Loading the background.


On the right hand side of the screen is the properties pane.  Here we have 3 tabs, Edit, Project and Create.  Make sure Create is selected.   Make sure you have the balloon animations files as well which are under Sesson1 of the Resources Folder.
1. Click on the Create New Image Map button as shown and load back1.png from the root of the Session1 folder – you may need to navigate back to it.


2. Now you have the back1.png loaded, drag the image across to the “playfield” as shown.


3. Next we want to resize it.  First use the mouse wheel to zoom out on the camera view so you can see the entire game screen as follows.


4. Next click on the back1 graphic in the middle of the screen and resize it to cover the outer box on the screen as shown using the blue dots which are handles on the sides of the object.
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1. Next we want to add a balloon.  So repeat the process above by click on Create New Image Map and this time bring in balloon1.png


2. Now drag it across to the middle of the screen as shown.


3. Okay, time to save as see what happens.  Click on File -> Save As...  You will be saving this current level.  There can be many levels in one game.  In this game, there will only be one level.  Call it level1.t2d




4. Next we want to run the game.  So click on the Play button at the top row of icons in T2D.


5. You should see this.  Not a game, but at least what you just did was load up some graphics and got the game shell to run.


[bookmark: _Toc310968346]Adding our first behavior.
What’s up with this?  Why does it do nothing?  Because we need to describe how it behaves in the game.  These sets of instructions are called behaviors.  They define how object acts in the game.  For balloons we want them to rise and when they leave the screen they disappear.  
1. Press the X button on the top right hand corner of the window to close the game.  It will take you back to the editor.
2. Click on the balloon if not already selected, and on the right hand side were you found Create, select Edit instead.


3. Now look down the Edit set of controls and you will see Behaviors.  Click on the wide bar which is the “dropdown” and you will see a list of behaviors that can be assigned to this balloon.  Select “MoveUpScreen” – if you hover your mouse over it, it will tell you how it works.


4. Now if you click on it, it will be the main one selected in the Behaviors list.  You will need to add it to the object, by clicking on the big green plus button to the left as shown.


5. Now that it’s added you can see it has more settings.   For now, let’s just save and then run the game as before by pressing the Play button.  Get ready to hit the X button.





6. You will see this.  The balloon will travel up the screen and disappear off the top.  Press the X button to close the game and return to the editor.
7. 

8. Let’s have a closer look at the behavior.  It has a setting for it.  Currently it’s set to -10.0
9. 

10. Change this to -5 and play the game again.  What happens?  Close the game and change it to 8 (note take out the –tve sign, but don’t use+ Plus is implied if a number doesn’t contain a – tve sign at the front) Run the game again.  What happens?  Doesn’t really go up the screen anymore does it?  In fact it goes down the screen?  While the behavior is called MoveUpScreen it’s no longer doing that.  It’s because the input field where you just typed in 8 is flexible.  
11. 

The balloon goes off the screen never to return.  Let’s change that.  While still having the balloon selected in the editor, click the Behaviors dropdown again and this time select World Limit Wrap drop down – not the Random one. Then hit the green + button to add it.               
[bookmark: _Toc310968347]Changing the world limit.
1. Now we need to set the World Limit of the balloon.  Wave your Mouse over the balloon then carefully raise the Mouse up until a small menu of buttons appears above it.  Move your mouse over the World Limit button and then click on it.


2. You will see the next screen.  Use the control handles to shrink it be the same size as the outer box.  Then press the ESC key to go back to zoomed in. This tell the balloon where it’s world limit it.  All objects can have different world limits.


  
3. Save and run the game.  The balloon will drop off the bottom then reappear on the top continuously.
4. Change the MoveUpScreen value back to -10.  This a more predictable behavior for a balloon.  
5. It’s a little too predictable actually.  Remove the World Limit Wrap by clicking on the Remove This Behavior button as shown.


6. Use the Behavior dropdown and select World Limit Wrap Random this time, then hit the + button to add it, and run the game.  Observe the difference.  It appears anywhere from the bottom when it wraps around.


  
7. Bearing in mind that the aim of the game is to click on the balloons to pop them, this makes it a little more challenging. 
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Now we want to make it so you can click on the balloon to pop it.  We need to add a pop graphic, and a behavior so the balloon detects click.  Follow these instructions.
1. Click on the Create tab, then click on the Create a new ImageMap button, and load the PopGraphic.png 


  
2. Your sprite list should now look like this.


3. Select the balloon on the playfield again.  Let’s add a behavior now so we can click on it.  Hit the Edit tab at the top, then the Behavior dropdown again and this time click on the Mouse Down Remove to select, and add it with the green + button.


4. Your list of behavior should look like this.


5. Run the game now.  When you click the balloon it disappears and a Pop graphic appears in its place.  But there’s only one – we want lots more.  Remove that behavior and add the Mouse Down Respawn and run again.  This time the balloon disappears and another appears somewhere else on the screen.  Try seeing how quickly you can dispatch the balloons.


[bookmark: _Toc310968349]Adding sound effects.
1. Okay so let’s add some sound now.  Sound is fired off using a behavior as well but in order for the behavior to run we need to add a graphic object to attach the behavior to.  Go to the Create tab, and click on the Create a new Image Map button, this time picking the audioIcon.png
2. Once loaded drag it to the playfield, but put it outside the screen as shown.


3. Now click on the Edit tab with the audioIcon selected and add the AudioManager behavior to it.


4. Next we want to give it an instance name so it can be referred to by the rest of the behaviors, so scroll down and select the Scripting section.  Expand it and add the name AudioHandler exactly as spelt.


5. Now run the game.  Whenever you hit the balloon it will make a pop sound.
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Next we will add scoring so that you get 100 points every time you pop a balloon.
1. Click on the Create tab, collapse all the sections as shown using the arrows marked, and then drag a Text object onto the Stage.  Type in the word Score:


      
2. Now it’s opened the properties for the text.  Under Scripting change it’s name to ScoreText.


3. Then look back up the properties and look TextObject.  Change “Character Height” to 4, and uncheck “Hide Overflow” so it can resize when score is add.


4. Next we need to add a behavior to the ScoreText object.  So go to the Behavior section then select and add the GUI behavior, “Keep Track Of Score”.


5. Now save and run the game.  Your score will go up when you pop a balloon.
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We’re almost done with this game, but it needs some variety.
We will do this by adding another balloon which will move randomly, but wrap around normally.
1. Go back to the Create tab and from the Static Sprites section, drag another balloon on to the playfield.
2. Click on the balloon and change it’s World Limit to the full screen.  Press ESC when done.


3. Click on the Edit tab and while having the balloon object selected, add the following behaviors and settings.
4. WorldLimitWrap
5. MoveOnScreenRandom 10 and 10
6. MouseDownRespawn.
7. So your Behaviors for that object should look like this.


8. Run the game and you should have two balloons at a time, and one of them moves in different random directions.


We will now add a new balloon type.  So you’ll need to load balloon2.png
1. Click on Create, and on the Create new Image Map button and load balloon2.png
2. Drag it onto the playfield.
3. Set it’s world limit as above.
4. Add the following behaviors and settings.


5. Save and run the game now and every time you hit the purple balloon you score 300. 
Okay time to finish it off.  Let’s add more balloons, but you can just copy and paste the one’s on the playfield so it keeps all the settings.
1. Click on one of the red balloons on the playfield, the press CTRL +C and then CTRL + V. 
2. Now click on the same balloon and drag it away.  You will have a copy.


3. Continue with both coloured balloon until you have a few on screen.


4. Save and run the game.  Balloon popping fest!  Well done.


Congratulations: You are a maker of games!


(P.S. Don’t forget if you used the Desktop to move your file to more permanent storage)








[image: Tet312-Game]

The first MS_DOS version of Tetris, 

developed in Russia in 1985,

one of the most famous computer games.
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Pong is one of the oldest video games.  It is certainly the first game to be used to make money.  You can follow the history of Pong here on YouTube.
http://www.youtube.com/watch?v=j-cpN7MlMhY
Pong was the game which first made video gaming popular when it was released in 1975. It was the first video game that most people had ever played. It was the first game produced by Atari, in the days before personal computers, and is still played today over thirty years later, for example there is a PlayStation version. The Classic Gaming website has this to say:
Pong, while not the first videogame, was the first coin-operated arcade game and the first mainstream videogame that was available to almost everyone. Pong was the impetus for the development of the videogaming industry, almost single-handedly creating both the home and the arcade videogame markets.
http://www.classicgaming.com/museum/pong/
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1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session2.
2. Next go to the Resources folder for this unit, locate Session2 and paste that into the T2DSemester1 folder under Session2. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.

[image: ]  
1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in Pong. Click on the browse button to the right of Location and navigate very specifically to YOUR hard drive.  Once you are in that folder click on Open which will  save it to a folder called T2DSemester1\Session2.  So your final destination will be something like “E:/ T2DSemester1/Session2”. 
3. 
Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.
4. Next go to the Session2 folder, copy the “behaviours” folder and navigate to Pong/game and paste the behaviors folder in here to overwrite the existing one.
[image: ]
5. Go back to Torque and click on the Project tab, then click on Reload Project.  This will load all the behaviors. If it asks you to save the current scene, save it as “level1”.
[image: ]
6. NOTE – you will need to follow this procedure for every game from now on.
As before first step is always to write a short description of a new game:

Two players battle is out on the Game Grid bouncing a ball across the arena.  If the ball gets past them, the other player scores a point.  The one with the highest score wins.

This forms what’s know as a functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our Pong game, the functional spec is a little more complex than the first game.
1. Show screen.
2. Load the paddles, ball and background.
3. Spawn the ball from the player to the left.
4. Allow both players to control their paddle using the keyboard.
5. Bounce the ball off the top and bottom of the screen.
6. If the ball passes left or right out of the screen the other player scores.
7. Update scores and each player gains more points.
The game never really finishes.  It’s going to be a survival game.  
Let’s bring in the assets first.
[bookmark: _Toc310968354]Creating the game grid.


On the right hand side of the screen is the properties pane.  Here we have 3 tabs, Edit, Project and Create.  Make sure Create is selected.   Make sure you have the assets files as well (as mentioned at the beginning of this chapter) which are under Sesson2 of the Resources Folder.
1. Click on the Create New Image Map button as shown and load back1.png from the root of the Session2 folder – you may need to navigate back to it.


2. Now you have the back1.png loaded, drag the image across to the “playfield” as shown.
[image: ]
3. Next we want to resize it to fit to the outside square.
[image: ]

[bookmark: _Toc310968355]Adding the paddles.
1. Now we need the paddles.  These are what the player uses to hit the ball.  Click on the Create tab and load the paddle.png image.
[image: ]
2. Drag it onto the screen and position it to the right.   Then wave your mouse to the top of the paddle graphic and click on World Limits for the object.
[image: ]
3. You need to set the right hand paddle to have its world limit to be just a small strip up the right hand side of the screen as shown.  Also in the Edit tab select World Limits section and change it to CLAMP.  Press ESC key to exit the World Limit setting mode.
[image: ]
4. Next, we want to add the behaviour to control it.  Open the section called Behaviors under the Edit tab, select Movement Behavior and then click on the GREEN + button to add it.  Simply selecting it, is not enough to add it.
[image: ]
5. See how it’s set the up and down key for you?  The vertical speed it also selected.  You can change any of these, but don’t right now.  
6. Save the game and run it by clicking on the PLAY button at the top of the screen.
[image: ]
7. If you have done it all correctly you will be able to move the paddle up and down the screen on the right hand side and it will stop at the top or the bottom.   Close the game and then change the speed to 40 and run again.  This might be a more suitable speed for you.  When you have found a speed you like, quit the game and move on.
8. Let’s add a new paddle but this time, click on the existing one on the game screen, press CTRL +C and then CTRL +V and move it over to the other side.
9. Next wave your mouse to the top of it to bring up the mini-menu as shown and select the world limit.
[image: ]
10. You’ll notice it’s in the same position as the old one.  Just click in the middle of the World Limit box and drag it to be over the left one as shown.
[image: ]
11. Click on the Edit tab and change the Behavior up and down keys by click on up then selecting A and then down and selecting Z.  Save and run and you will be able to control both paddles with A/Z and UP/DOWN keys.
[image: ]
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The original design of Pong has the ball bouncing off the top of the screen and the bottom, and also the players paddles.  We can do this in two steps (just read).  We first want to set the world limit for the ball so we know when the ball has reached the screen edges.  After that we will detect when the ball hits the paddles.
1. Load the ball.png graphic using the Create tab and clicking on the Create new image map icon.


2. Drag the ball on to the game grid so it sits at the top and in the middle as shown.
[image: ]
3. We need to see it world limits, so wave your mouse over the top of it to reveal the mini-menu and select world limits.
[image: ]
4. Change it so the top and bottom align with the screen and the left and right go a little bit off.  This is so it bounces off the top and bottom of the screen but when it goes to the left or right it disappears letting the player know for certain they lost the ball.
[image: ]
5. Press the ESC key to close the world editing mode and then make sure you are in the Edit tab.  Scroll down and find Physics and set the properties as follows.  Uncheck others as shown.
[image: ]
6. The Receive collisions allow other objects in the game to know when the ball has made contact.  The callback calls a bit of script to work out collisions.  We’ll look at that in a minute.  
7. Now that we are aware of scripts scroll up and expand the Script section, then change the Name to Ball.  This allows script to identify this and control it.
[image: ]
8. Scroll further up and we’ll add those script I’ve been talking about.  Find the Behaviors section and add the following behavior “Ball Control”.
[image: ]
[bookmark: _Toc310968357]Understanding Behaviors and TorqueScript.

Note to the Lecturer and Students.  There is a section in Session 10 and it is complicated, boring and very uncool. The plan is, you will get there in week 10 and come back here to Pong to understand this.  Lecturers and Students both have the choice to completely ignore all this gibberish I am about to spout in there, and just jump to “Testing the ball bounce” below.   You can come back to this later if you want, even after you have completed Pong as you don’t need to know it right now.  You could also come back after Space Attackers and revise this section.  It’s all about TorqueScript and how I have slaved literally weeks to write the code “under the hood” for you, so you can just have a nice drag and drop game creation environment.  You have been warned!
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Run the game now.  The ball will bounce off the screen top and will reset off the middle of the screen when it goes off the screen.  We won’t see the score up date and it only ever starts at the middle of the screen because neither paddle right now can bounce the ball and the game doesn’t even know where the paddles are.  We’ll fix that now.  Resize the ball if you want to.
[bookmark: _Toc310968359]Hitting the ball back with paddles.
We need to add collisions to the paddles to make them bounce the ball back 
1. Click on the left paddle and then click on the Edit tab.
2. Scroll down to Scripting and change the name to Player1 as shown.  This means we can control it via script.
[image: ]
3. Scroll down to Collisions and change as follows.  This will send a collision to the ball so the ball knows when the paddle comes into contact.
[image: ]
4. Now select the right paddle and do the same again, this time calling it Player2 in the Scripting section.
[image: ]
5. Next scroll down to Collision and change as shown below.
[image: ]
6. Run the game, you will be able to hit the ball back and forth.  If you miss it, the other player serves.  Notice I’ve shrunk the ball.
[image: ]
7. Speed the ball up if you want by click on the ball, clicking on Edit tab, scrolling down to Behaviors and change the ball speed to 20 or something.
[bookmark: _Toc310968360]Scoring.
Next we want to show the scores on screen.  This is done by drawing text to the screen and tagging it with a name like we did with the paddles and the ball so they can be controlled with script.
1. Click on the Create tab and scroll down to the bottom.  Drag a Text element to the left of the centre as shown.  
[image: ]
2. When you release you will be able to change the Text style, colour and font.  It will automatically go to the Edit tab for you.  Press the number 0 and 0 will appear on the screen and uncheck Hide Overflow – this will allow the text to take up more or less room as required when the score changes.
[image: ]
3. Scroll down to Scripting and change the name to Player1Score shown.
[image: ]
4. Go back to Create tab at the top, and drag out another text object, this time just to the right of the middle of the screen.
[image: ]
5. Again press 0 to make a 0 on the screen, make sure it’s size 10, and Hide Overflow is unchecked.
[image: ]
6. Scroll down to Scripting and change its name to Player2Score.
[image: ]
7. Finally select the Ball object on the screen, click on Edit tab, scroll down to Behaviors and add Keep Track of Score.
[image: ]
8. Play the game now and if either player misses the ball the other player’s score goes up.
[bookmark: _Toc310968361]Adding Sound.
We are about to add the last bit for this game.  We need to add sound. We do this by adding a placeholder graphic off screen and assigning an audio behavior to it.
1. Click on Create new image map and load AudioIcon.png
2. Now drag the icon off the top of the screen as shown.
[image: ]
3. Click on the Edit tab and scroll down to Behaviors.  Add the Audio Handler behavior.
[image: ]
4. Scroll down to Scripting and change its name to AudioHandler as shown.
[image: ]
5. Run the game now and you will hear sounds when the ball bounces off the screen, is lost or gets served.
[image: ]
Well done you’ve made two games now!   You are certainly on the way to learning the dark art of Video Games Development.
[image: original pong]

The original Pong 
(home not arcade version). 

Notice the controls.








[bookmark: _Toc310968362]Application #3:  Space Attackers

Space Invaders is the original vertical shooter.  Like Pong it was released commercially.  You can follow the history of Space Invaders here on YouTube.
http://www.youtube.com/watch?v=WCeUHpallMI
	Space Invaders was first released in 1978 in Japan. It became so popular the government had to mint more coins as so many were being put into arcade consoles like this.
It is one of the most successful and influential video games of all time.

 (
Alien spaceships are attacking. You as the defender can return fire with your laser canon. There are blocks y
o
u can hide behind to protect you from their fire, but your own fire 
will
 destroy your cover.
)The game description is:
	[image: cabinet]




Play the game placed in the network folder to get a mental picture of what you will be making.
The original Space Invaders had three types of alien spaceships in five rows which advanced down the screen firing at the laser canon of the defender at the bottom. We will start by making sprites for three types of invaders, and the missiles, bases and explosions.

	[image: Space_Invaders]
	This original display on the left was monochrome with an overlay to make some objects look coloured. But later versions used colour graphics and so can we!

We will make three sprites, each one a different colour. Later we will animate them.




[bookmark: _Toc310968363]ASEPRITE – Create your own sprites.
Torque doesn’t have an integrated sprite editor so I have found an excellent one that can create that retro-80’s feel.  You will find it in the Programs group.
1. Click on New and create a 64 x 64 sprite with these settings.
2. [image: ]
3. Click on Okay to create the image.

Here’s a list of the all the tools and then the same toolbox expanded so you can see the other tool sets.  Hover your mouse over tool to see how it’s used.
[image: ]
Marquee / Selection [image: ]
Pencil / Spray [image: ]
Erase / Colour Pick / Move [image: ]
Lines / Curves [image: ]
Shapes outlined and filled [image: ]
User drawn shapes [image: ]
Blur tools [image: ]

The last tool is the Configuration tool and allows you to change the size of the tool you are drawing with and it’s opacity (how much colour show through over other colours) amongst other things.
[image: ]
1. Pick the Pencil and pick a colour – I’m going to draw all these images.
2. 

3. First to create that block 80’s feel I’m going to use the filled rectangle tool to block out the basic shape.
4. [image: ] [image: ][image: ][image: ]
5. Next I’m going to change colours and draw the eyes and mouth.
6. [image: ] [image: ][image: ]
7. Next I’m going to detail him with a darker green.
8. I’ve zoomed in a bit using the mouse wheel which brings up a thumbnail of the entire image as well.  I’ve zoomed in to make it easier to paint.
9. 

10. Next I’m going to give it a black border with 1 pixel lines and some pupils.
11. 

12. Now I want to animate it, so I will add 1 frame from the menu at the top.
13. 

14. You don’t see unless you wave your mouse down the bottom but it has the animation controls down there.  Select frame 2.
15. 

16. Move your mouse away and in the bottom left you can confirm which frame you are on.
17. 

18. I’m going to erase the legs and draw some inwards first.  You can see here I’ve chosen the filled box tool, I’ve sampled the outside green colour with the eye dropper and I’ve increases the pixel size to 12 and square.  Then I draw in 3 big blocks per leg.
19. 

20. Now I’ll use a 1 pixel brush and outline it again.
21. 

22. Then I’ll finish off by redrawing the eyes so they shift to the level.
23. 

24. Okay time to add a new frame, but I want the first one, so I’ll use the animation controls to go back 1 frame.
25. 

26. I want to copy this for frame 3 so I use the Marquee select and press CTRL + C.
27. 

28. I go to frame 2.
29. 

30. Then I add a new frame from the menu (or you can press N)
31. Now I am on frame 3, I press DEL to delete the current image (as long as you still have the Marqee select.
32. 
  Press DEL now.
33. Then I press CTRL + V and I have the object like this with control handles on it.
34. 

35. Using the controls and by holding the mouse over the centre of the image I get the Hand sprite.  Click and hold and drag in to place.
36. 

37. Press ENTER to lock it down.
38. Go to frame 2 now using the animation controls and marquee select the 2nd frame.
39. Go to the 3rd frame and press N to add a new frame.
40. With marquee still selected delete the current frame.
41. Paste and move the copied sprite into place.
42. This time redraw the eyes to face right.
43. 

44. Save the file as SpaceInvader1.ase
45. 

46. Now finally EXPORT to your T2DSemester1/Session3 folder as a Sprite Sheet, in PNG format.
47. 

48. 

49. 

50. When completely saved it will come back looking like this in ASEPRITE.
51. 

52. All ready for Torque.  
[bookmark: _Toc310968364]Make your own graphics.
Now that you have some basic skill in ASEPRITE go and make the following assets – mine are here for inspiration and guidance – make your own!
· Player
· Base (notice it has 4 frame of deterioration)
· Invader2
· Explosion sequence
· Alien bullet
· Player bullet
· Mothership

 Alien bullet.

 Invader 2.

 Base sequence.

 Explosion sequence.

 Player ship sequence.

 Mothership.
Make a background scene and game over if you want but I have provided those for you to save time.
[bookmark: _Toc310968365]Putting the game together.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session3.
2. Next go to the Resources folder for this unit, locate Session3 and paste that into the T2DSemester1 folder. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.

[image: ]  
1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in Space Attackers. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session3.  So your final destination will be something like “E:/ T2DSemester1/Session3”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create butto


4. Next go to the Session3 folder, copy the “behaviours” folder and navigate to SpaceAttackers/game and paste the behaviors folder in here to overwrite the existing one.


5. Go back to Torque and click on the Project tab, then click on Reload Project.  This will load all the behaviors. If it asks you to save the current scene, save it as “level1”.
[image: ]

NOTE – you will need to follow this procedure for every game from now on.  From now I’m going to say copy all the resources and paste the behaviors in the correct folder, then reload.
Let’s look at the functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our Space Attackers game, the functional spec is a little more complex than the first game.
1. Load background, aliens, bases, missiles and player.
2. Place a swarm of aliens on screen.
3. Allow both players to control their space ship using the keyboard.
4. Allow the player to fire missiles.
5. Missiles will destroy the enemy, and you gain points for doing so.
6. Update scores and each player gains more points.
7. Aliens march down the screen.
8. Sometimes aliens will fire back.
9. Bases block missiles from hitting the player.
10. Player has 3 lives.
The game is won when all aliens are dispatched.  
Let’s bring in the assets first.  Well.... there aren’t any.  Let’s make our own.  Sure we have a background, but we don’t have any aliens, player ship, bullets and explosions.  We’re going to use a cool free program called ASESPRITE.  This makes really good pixel art and animation.
[bookmark: _Toc310968366]Loading the assets – adding the player.
1. Load the player spaceship first by click on Create new image map.
2. 


 
3. Double click on the space ship image under the section Static Sprites and change to CELL to set it up as sprite sheet, change the cell width and height to 64 x64 and Save.
4. 

5. Next click on the animation button.
6. 

7. Select the sprite sheet you just set up from the list (this is the only one there right now) the click on Select.
8. 

9. To add all frames to the animation, double click on each of the big images as shown and they build a sequence at the top.  Set animation speed to 10 frames per second and call it SpaceShipAnimation, make sure CycleAnimation is ticked and click on Save.
10. 

11. Notice that there are now 2 types of the same space ship, Static and Animated.  We will be using the Animated version of the space ship soon.
12. 

13. Next Create new image map and load in SpaceScene0001.bmp.  Drop it into the scene from Static Images, and drag in the player but take it from Animated Sprites as shown.
14. 
  
NOTE I’m speeding things up now, because you should know how to do this.  If you do not, go back to the previous games in the book to find out how to resize, load, etc.
[bookmark: _Toc310968367]Adding movement to the player.
Click on the player in the scene, then click on the Edit tab and add the Movement Behavior from the list.  You will notice I have written a heap of behaviors for this one.  We are also reusing behaviors.
15. 

16. Save and run the game.  You will be able to move left and right so far.  Stop the game.
17. 

18. Next let’s set the world limit for the player so they stay on the screen.  Hover your mouse over the player sprite while selected and click on the World Limit mode.
19. 

20. Press ESC to get out of this mode.
[bookmark: _Toc310968368]Firing missiles.
The player also has a control to fire missiles which is already coded in, we just need to load the asset for it.
1. Create a new image map and load in the missile1.png.
2. Select the player sprite on the screen and select Edit tab.
3. Click the drop down for firing and change to SPACE.
4. Run the game now and you will be able to fire.
5. 

[bookmark: _Toc310968369]Adding the invaders.
The invaders have animation (you should have animated them) so load up Invader1,2 and the Mothership.
1. Select the first Invader by double clicking on it and change it to CELL, 64 x64. 
2. 

3. Create a new animation.
4. 

5. Select the Invader1ImageMap from the list and click on Select.
6. 

7. Now as before double click on each of the big images to make the sequence,  set the frame rate to 2, cycle the animation and save as Invader1Animation.
8. 

9. Now repeat steps 1 to 8 for the Invader2 and Mothership.  Invader2 is 64x64 and Mothership is 32 x 16.  Mothership runs at 10 frames per second.

[bookmark: _Toc310968370]Moving the invaders.
We will add the first invader to the screen and I’ll show you how to move him.  You’ll need Torsion open for this.  (see appendix for setting up a Torsion project).
1. Drag the Invader1 animation onto the screen, select Edit tab and add the Enemy 
2. Navigate to behaviors and then right click and open enemyControl.cs with Torsion.
3. Scroll down and locate this onUpdate function.
4. 

5. Where the arrow is we need to add some code to make the invader move across the screen.  The way the invader moves is it tracks left or right across the screen and when it has moved a certain amount it swaps direction and moves down the screen a little bit.  Here’s how we do it.
6. 

7. Write the code in that is not greyed out.  Line 42 controls a variable called %this.shimmy.  The way shimmy is updated is by taking away the absolute value of %this.xMove.  That’s what mabs() does.
8. Next we ask a question; has the shimmy been reduced to 0? This is what line 45 says.
9. You’ll notice the { } curly braces.  Don’t get these mixed up with the () round braces.  The curly braces “contain” the lines 47 to 55.  So this is to say, if the shimmy has been reduced to 0 then do ALL these things in this order.
10. Line 47 is a comment, which is green and all comments are preceeded by two slashes //.  Comments are ignored by the game and are for us humans to understand what the code is doing.  You should comment for each line of code to remember how things work.
11. Line 48 copies the value of %this.memShimmy into %this.shimmy, essentially resetting it so that it can start the shimmy process again.
12. Line 50 is a comment.
13. Line 51 creates a temporary variable (a word that contains a value for you) by getting the Y position of the invader (it’s position up and down the screen) and modifies it by the vertical speed.  This makes the invader move down the screen a little, ready to make back the other way.
14. Line 52 passes that computed position into permanent storage for this invader.
15. Line 54 is a comment.
16. Line 55 flips the direction of the invader so if it’s going left it now goes right or vice versa.
17. Save the file, and go back to the game in Torque.
18. Run the game and the invader will move back and forth across the screen and move down the screen when it reaches the shimmy limit.  When it gets to a certain position is just disappears.  We need to adjust its world limit.
19. Exit the game and click on the invader again.  Hover your mouse over the top and select the world limit.
20. 

21. Change the world limit to cover the entire screen.
22. 

23. Run it again, and it will move all the way down the screen.  You can also shoot it if you want.  But it just disappears.
[bookmark: _Toc310968371]Adding explosions.
We want to see something more exciting that a vanishing invader.  So we need to add the explosion sequence and generate one in the place of the enemy when they get hit by our bullets.
1. Click on the Create tab and load the explosion1.png image.
2. Double click on it and change it to a CELL image of 64 x 64.
3. Create a new animation and click on the PLUS button this time to add all frames.
4. Change the speed to 15 frames per second.
5. UNCHECK cycle animation, because we only want it to explode once.
6. Make sure it’s called Explosion1Animation so the scripts can use it.
7. 
 
8. When you shoot the invader now, it will explode.
9. 

[bookmark: _Toc310968372]Adding Sound Effects.
You will probably remember that to add sounds we need to load the Audioicon and add the sound manager behavior to it.  It’s still the same this time. I have already coded the behaviors to fire off sounds.  So lets set it up and we can dissect a little bit.
1. Click on the Create image Map icon.  Load the AudioIcon.png
2. 

 
3. Drag the AudioIcon on to the scene above the main screen as shown (so it won’t be seen in game)
4. 

5. Click on the Edit tab and while the AudioIcon is still selected scroll down to Behaviors and add the AudioManager.  Then scroll down to Scripting and name it AudioHandler (all one word as shown)
6. 

7. Save the level and then run the game.  You will now hear sounds for shooting and destroying the alien.
[bookmark: _Toc310968373]Adding the Score.
The score is essentially a text object we drag onto the scene and attach a behavior to.  It needs to be named as well.
1. Click on the Edit tab and scroll down to the “Other” section, to find the icon with ABC on it.  Drag it across onto the scene and put it up the top.  Immediately press the key 0 (zero) to show a white 0 on screen.
2. 

3. The Edit tab will already be selected and you will be in TextObject mode.  Change the text size to 4, the Hide Overflow should be unchecked.
4. 

5. Now scroll down to Behaviors and add “Keep Track of Score”.
6. 

7. Finally we need to name it so scripts can use it.  Scroll down to Scripting and call it “ScoreText” as shown.
8. Save the level and run the game.  You will now score 100 for the enemy.
[bookmark: _Toc310968374]The Enemy strikes back.
The enemy can fire bullets, so let’s add the artwork, then add the behaviors to the enemy to shoot you.
1. Create new image from from the Create tab, and load the alienMissile.png
2. Select the enemy, and select the Edit tab.
3. Scroll down to Behaviors and add Enemy Bullets behavior as shown.
4. 

5. 
There are parameters you can tweak, but for now just run it and see the effect of the enemy firing.  You’ll find the bullets drop way too slowly to be of any bother.  
6. Go back to the behavior and adjust the verticalSpeed to 30.  The other settings determine how long to wait before checking to see if the alien fires again (2 seconds), and the random chance at the 2 second mark out of 100 that it will actually fire.  Adjust these to suit your own requirements.
7. 

8. When you run it you will notice the player doesn’t get hit.  This is because the player’s collisions are turned off.  Click on the player, click on the Edit tab and scroll down to collisions.  Change as shown.
9. 

10. Also go up to Scripting and change the name of the ship to Player as shown.
11. 

12. Run it now and when you get hit, you will see and explosion but other things need to happen.  Things are going on under the hood that need to be enabled, such as the player lives and the game over screen which we haven’t add yet.
[bookmark: _Toc310968375]Adding Lives.
The player lives are handle using a representative sprite, and a behavior.  This way you can tell the system where you want the lives to be placed and how many lives the player has.
1. Drag a copy of the player spaceship (the imagemap – the animated one) to the top of the screen around the middle along the same line as the score. Shrink it as shown.
2. 

3. With the space ship still selected, click on Edit tab and scroll down to Behaviors.  Add Handle Lives.  Scroll down to Scripting and name it “LivesManager”.  Now the scripts can find it.  Leave it at 3 lives, and adjust the spacing in the Handle Lives screen as required.  Play the game now and you will lose lives, and reset in the middle of the screen.  Eventually you won’t be respawned.
[bookmark: _Toc310968376]Showing Game Over.
Now we have an end game scenario, let’s show the player when they have died.
1. Create a new image map and load GameOver.png
2. Drag a copy of one into the middle of the screen and enlarge it to about the size you see below.
3. 

4. Click on it, select Edit tab, scroll down to Scripting and name it “GameOver”.  Scroll up to Scene Object and uncheck Visible.  It will now disappear.  When you lose all your lives it will reappear, letting the player know the game is over.  Try it now.  Let the enemy shoot you until Game Over appears.
5. 

[bookmark: _Toc310968377]Adding more invaders.
We’ll add a row of invaders side by side to add more challenge to the game.
1. Select the only invader on the screen and press CTRL + C to copy it.
2. Press CTRL + V to paste a copy.  You won’t see it as it’s on top of the other but hold the SHIFT key and tap the RIGHT ARROW key and move it to the side.  Continue this process until you have about 8 along one line as shown.   However delete the Bullet behavior from some of them otherwise it will be too hard.
3. 

4. Play the game now and they all move along.  Shoot them for score.
[bookmark: _Toc310968378]Adding a new invader.
There’s a pink invader as well (yours might be a different colour).  We’ll use that one.
1. Drag the animated version of that pink one on to the scene.
2. 

3. Click on the Edit tab, and add the following Behaviors; “Sets A Score” and “Control Enemy With HP”.
4. 

5. Change the score value to 150.
6. Change the hitpoints to 3
7. Wave your mouse over the top of the pink invader and change its world limit to the full screen otherwise it will disappear randomly.
8. 

9. 

10. Press ESC to exit the World Limit mode.  Now the enemy will require 3 hits to destroy and you will receive 150 for that one.  
11. Add the behavior “Enemy Bullets” to make it fire back, but increase its verticalSpeed for the bullet as before to 30.  If you want you could also reduce its Delay and onRandom to make it fire more often.
12. 

13. Make a row of them by copying and pasting like you did before, but tap SHIFT + RIGHT twice per enemy to space them as shown and play it.  However delete the Bullet behavior from some of them otherwise it will be too hard.
14. 

15. They will be more challenging because they are harder to kill.
16. Save the level and play it now.  It’s much harder.
17. Continue to fill up the screen with a combination of green and purple aliens by copying them.  Here’s my set up.
18. 

19. You could also make them smaller if you want.  Play it a few times.  I tended to get shot quite easily.  We need to add barriers to over some defence.
[bookmark: _Toc310968379]Adding Defence Barriers.
You should have created a Barrier Sequence which looks like this


We need to load this image and make it into an animation sequence.
1. Create a new image map and load barrier.png
2. Double click on the image and change it to CELL of size 32 x 32.
3. 

4. Now click on the Create Animation button.
5. 

6. Use the BarrierImageMap and click on Select.
7. 

8. Drag only the first frame to the top (so we can see it to place it – we’ll animate it later), change frame rate to 1, uncheck cycle animation and call it BarrierAnimation so the code can find it.
9. 

10. Now we need to carefully place these blocks to form a barrier.  This can be done by setting up the grid snap.  Click on the menu at the top, by selecting Edit ->Preferences.
11. Change the grid size to 1 x 1, and tick snap to X and snap to Y
12. 

13. Click on Okay, drag the BarrierAnimation on to the stage, zoom in close with the mouse wheel and place near the player.
14. 

15. Click on Edit and add the behavior “Barrier Settings”.  Leave it at -1 and set collisions as shown.
16. 

17. When you run it the block is never destroyed.  We can create a barrier this way.  For the example copy and paste blocks to make this shape.
18. 

19. Running it now you have a place to hide to avoid being shot.  You could copy and duplicate this shape but let’s not.  Let’s make it more like the original.  Undo until you have only 1 and change its damage to 3.  
20. Copy and paste that one to make the shape and then copy and paste the entire shape to make 3 more based.
21. Now you can use the old tactic of shooting out a hole in one of the barriers and destroying the enemy from there.
22. Then double click on the BarrierAnimation in Animated Sprites under the Create tab and add the 3 remaining frames.
23. 

24. Here’s how it’s looking.  I resized all the aliens by moving the background out of the way and group selecting all of them.  Then I shrunk them all down.
25. 

26. Then I grabbed one column at a time and select the Align button as shown.
27. 

28. Then I move the background back, and it looks like this.  Pretty sweet huh?
29. 


[bookmark: _Toc310968380]Adding the Mothership.
The mothership is bonus item that scoots along the top of the screen.  It is very small, moves very fast and doesn’t appear that often.  Let’s add it to finalise the game.
1. Click on Create tab and drag the mothership to the left of the scene, off the scene.  We want it to appear from off the screen to start with.
2. 

3. Click on Edit tab and add the behavior “Saucer Control”.
4. 

5. The horizontal speed can be increased if you want to make it harder to hit.  The appearOn variable in measure in chances out of 100.  The wait is used to wait x number of seconds before testing if it’s going to appear on the chance already specified.
6. Add a Set Score behavior to it as well and make it worth 1000 points.
7. 

8. Next hover your mouse over the saucer and select its world limit button.
9. 

10. Change the world limit to this shown below then press ESC to exit world limit mode.
11. 

12. Okay the game is complete.  Run it and enjoy!  I find the mothership doesn’t appear often enough, so change it’s appearOn to 80.

Congratulations on completing your 3rd game.


[bookmark: _Toc310968381]Application # 4: Path Finding.
This is a mini game which serves to explain to you how the path finding for PuckaMan (next game) works.
[bookmark: _Toc310968382]Getting Started.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session4.
2. Next go to the Resources folder for this unit, locate Session4 and paste that into the T2DSemester1 folder. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1if you see this pane.

[image: ]  
1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in PuckaMan. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session4.  So your final destination will be something like “E:/ T2DSemester1/Session4”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


As before first step is always to write a short description of a new game:

In an abstract land made of blocks a player must avoid the dreaded glitch.

This forms what’s know as a functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our PathFinder game, the functional spec is very simple.
1. Load the background, glitch and player.
2. Allow player to move around maze without going through walls.
3. Allow glitch to chase player around maze.
Let’s bring in the code first.

[bookmark: _Toc310968383]Adding the Path Finding files.
The mini game will use A* (pronounced a-star) to allow the enemy to find a path to the player (and to avoid the player).  You will need to add some files first.  Copy over the behavior files as always, but you will need to add the gameScripts files as well.  You will find both resources in the Session 4 folder.  Refer to Session 1 on the Balloon Pop game if you don’t know what to do by now.
From the resources folder copy the contents of the gameScripts folder to here under and overwrite files already there.
 E:/ T2DSemester1/Session4/PathFinding/game/gameScripts

You will need to overwrite the gameScripts folder there.
1. Set up a Torsion project by referring to Appendix 2. 
2.  Using Torsion add these lines below to main.cs.  Be very careful which main.cs you open as there are two (it’s the one under game/.  This diagram will show you the code to add in, as well as which main.cs is required. 
*  See Appendix 2  if you are unsure about setting up Torsion for this project first.


NOTE.  Once you’ve added that code you can always test for errors in your typing by hitting F7 – this will pre-compile the code and make sure it’s not got obvious syntax (or incorrectly spelled command) errors.
3. Press F7 now.  It will most likely ask you to save the Torsion project.  Just go ahead and hit Save.


Once the compile finishes you will see this report at the bottom of Torsion.


Well done!  You’ve compiled your first program.  
[bookmark: _Toc310968384]Adding the assets.
We’ll need the block to draw the maze, the player and the glitch.  You’ll need to copy them from the resources folder first.  
1. Copy the 3 pngs and the whole beaviors folder from Session4 resource folder and paste into the T2DSemester1/Session4 folder as shown below.


2. Next copy the behaviors folder to inside the PathFinding folder under game as shown below.


3. Go back to Torque.
4. Click the Create tab.
5. Click on Create new image map.
6. 

7. Load barrierSimple.png, HappyFace.png and Smoke.png from the e:\t2dSemester1\PathFinding folder you just copied everything to.
8. You see all assets loaded under Static Sprites now like this.
9. 

[bookmark: _Toc310968385]Creating the maze.
The maze is done with a tile map.  A tile map is a grid filled with different sprites.  If a sprite is in one grid block and the collisions are turned on you can’t pass. 
1. Scroll down the Create tab and look for TileMaps.
2. Drag the tilemap icon into the scene as shown.  This will create a new grid onscreen.
3. 

4. Here’s the grid.  On the right hand size change the tile count x/y to 30 and tile size x/y to 5. Then press the size object to layer button to show all the tiles.
5. 

6. Click on Edit Tile Map.
7. Select the Barrier image map,  change custom data to 10 (you have to delete what’s in there and type in the number 10).  Tick collision, select the Pencil and start drawing a maze.


The 10 you wrote into the custom data is used by the path finding code to tell the enemy that they can’t go there.  The enemy will need to find another way around.
8. Press ESC when you have finished making the maze.  
9. With the tilemap still select scroll down the Edit tab to find Scripting and type in the name theGrid and change the class to pathLayer – this is important to name it just so – the engine will use this name.  (from the docs - This hooks the tile layer with the aStar $PathGrid global variable.)
10. Scroll to down collision and set as follows.
11. 

12. Press SAVE, save the scene as level1.t2d and it will ask you to save the layer.  NEVER name it the same as the level – name it layer1 or myMaze or something.
[bookmark: _Toc310968386]Adding the player.
The player will need to be created with particular settings in order for the Glitch to find it.
1. Go to the Create tab.
2. Drag the red happy face to the scene.
3. 

4. With the happy face in the scene select, click on the Edit tab, and scroll down to Behaviors.  Add the Shooter controls behavior which will allow you to move around.  See how we just borrow behaviors from another game and it works?  Great code reuse.
5. Shrink the player to be smaller than a block.
6. Scroll down to Scripting and add pPlayer (case sensitive) to Name, and the class to PlayerClass, again case sensitive.
7. Change the collision to as follows.
8. 

9. Save and run the game.  
You will be able to move around with the arrow keys and not go through the walls, however you can move off the screen and it doesn’t scroll with you.  We’ll fix that now.
[bookmark: _Toc310968387]Camera to follow the player.
Follow these steps to have the camera move with the player.
1. Click on the Create tab
2. Scroll down to Other and drag a Scene Object onto the player.  Resize to suit as shown below.
3. 

4. With the scene object selected click on the Edit tab.
5. Scale the object to be the same size as the maze.  You may need to use the mouse wheel to zoom out to see the entire maze.
6. 
Scroll down to Scripting and name it pSceneBounds.   By naming it this way when the add the Camera to the player it will know not to scroll outsize the extents of the maze.
7. Now select the player, click on the Edit tab, scroll down to behaviors and add the Camera behavior.  Change the objectInfo dropdown to pSceneBounds so the camera will use this extents of the maze.
8. 

9. Save and run the game.  You will now have the camera follow you around the maze as required.
[bookmark: _Toc310968388]Adding the Glitch.
Time to add the bad guy.  We’ll drop in the cloud image and connect it up to the path finding code to make it find the player.
1. Click on the Create tab.
2. From the Static Sprite drop the cloud into the scene and resize to be the same size as one of the grid squares.
3. 

4. With the cloud still selected click on the Edit tab.
5. Scroll down to the Scripting tab, name it pAI, class is AIClass and SuperClass is aStarActor.  This will allow it to use the path finding code.
6. 

Save and run the game. The glitch will follow you around and will retrace paths to find the shortest path to get to you.
This is a great technique for a lot of different maze games, especially .... drum roll ... PuckaMan!  Next session we will make that game with the same technique.

 
 


[bookmark: _Toc310968389]Application #5:  PuckaMan

PacMan has an interesting and significant place in the history of video games.  Watch this video.
http://www.youtube.com/watch?v=8i3KC3KKEXM

	Pac-Man was first released in 1979 in Japan. The Killer List of Videogames rates Pac-Man as the #1 video game of all time on its "Top 10 Most Popular Video games" list.

The game was developed by Toru Iwatani over eighteen months. The original title was pronounced pakku-man and was inspired by the Japanese phrase paku-paku taberu (the sound of a mouth opening and closing). Although it is often claimed that the character’s shape was inspired by a pizza missing a slice, Iwatani admitted later that it was a half-truth and the character design also came from simplifying and rounding out the Japanese character for mouth. Iwatani's efforts to appeal to a wider audience — beyond the typical demographics of young boys and teenagers playing sports games or space shooters like Space Invaders—lead him to adding elements of a maze.

It was the first video game which appealed equally to female and male players. The sequel, Ms Pac-Man, was even more popular and was the first major game to star a female character in the lead.
	[image: ]
The Japanese sales flyer from 1980 displays the Japanese title, PUCK MAN, as well as the original character design.

In America it was thought that Puck Man would be too easy for vandals to alter so the name was changed to Pac-Man.



Pac-Man was so popular it inspired a television cartoon series and a Top 40 single, the character appeared on the covers of Time and Mad magazines and led to over 30 sequels. 
The original game has 256 levels and can never be completed. Throughout the game “fruits” occasionally appear and give extra points if Pac-Man eats them. The information about them was kept in a single byte, which can only hold a number up to 255. So on level 256 the screen became garbled and the maze cannot be navigated. We will only create the first level.

	[image: ]
	


A screenshot from the original arcade version of the game, showing the four ghosts in their starting positions at the center of the screen and Pac-Man below. Four Energizers are visible near the corners of the screen. It was the first major game to use power-ups. 



[bookmark: _Toc310968390]Getting Started.

3. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session4.
4. Next go to the Resources folder for this unit, locate Session4 and paste that into the T2DSemester1 folder. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1if you see this pane.

[image: ]  
4. Click on the Create pane to get started.  
5. The next screen you will see is this (below).  In the Name box, type in PuckaMan. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session4.  So your final destination will be something like “E:/ T2DSemester1/Session4”. 
6. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


As before first step is always to write a short description of a new game:

Lost, somewhere in cyberspace, transformed into a rotund pie mouthed creature you must avoid being caught by the ghosts in the machine.  Eat energy pills to vanquish the evil sentients.

This forms what’s know as a functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our PuckaMan game, the functional spec is a about as complex as the Space Attackers game.
4. Load background, ghosts, sounds, player and items.
5. Allow player to move around maze without going through walls.
6. Allow ghosts to chase player around maze.
7. Player can each power pills and energy pills.
8. Energy pills will temporarily transform ghosts so they can be eaten.
9. Bonus fruit appears.
10. Clear all power pills to go to next level.
11. Player has 3 lives.
12. If player takes too long, ghosts will get faster.
Let’s bring in the assets first.  I have made all the graphics for you this time.  Here’s how it’s going to look.
[image: ]
[bookmark: _Toc310968391]Adding the Path Finding files.
Puckaman will use A* (pronounced a-star) to allow the ghost to find a path to the player (and to avoid the player).  You will need to add some files first.  Copy over the behavior files as always, but you will need to add the gameScripts files as well.  You will find both resources in the Session 4 folder.  Refer to Session 1 on the Balloon Pop game if you don’t know what to do by now.
Copy the contents of the gameScripts folder to here under and overwrite files already there.
 E:/ T2DSemester1/Session4/PuckaMan/game

You will need to overwrite the gameScripts folder there.
Using Torsion* or Notepad, add these lines below to main.cs.  Be very careful which main.cs you open as there are two (it’s the one under game/.  This diagram will show you the code to add in, as well as which main.cs is required.
*  See Appendix 1 if you are unsure about setting up Torsion for this project first.


NOTE.  Once you’ve added that code you can always test for errors in your typing by hitting F7 – this will pre-compile the code and make sure it’s not got obvious syntax (or incorrectly spelled command) errors.
Press F7 now.  It will most likely ask you to save the Torsion project.  Just go ahead and hit Save.


Once the compile finishes you will see this report at the bottom of Torsion.


Well done!  You’ve compiled your first program.  
[bookmark: _Toc310968392]Adding the assets.
Now that Torsion is ready, flick back to Torque and add in all the graphics in the Session4 folder you’ve copied over.
1. Click on Create a new image map icon in the Create tab ( you should know where this is by now) and press CTRL +A.  Add all the graphics in the folder.  One to pay particular attention to is TilesetPuckaMan.png.  This is the tiles for your maze.
2. Under Static Sprites click on TileSetPuckamanImageMap and change to CELL or 64 x 64 and save.  This will prepare it to be a tilemap.
3. 


[bookmark: _Toc310968393]Creating the maze.
The maze is created using a Tilemap.  
1. Under the Create section, collapse the Static Sprites and Scrollers sections so you can see the Tilemap section.
2. Drag one out to the scene.
3. Now the Edit section is shown.  Change the settings as shown and then click on Size Object To layer as circled.
4. 

5. Once sized, press ESC then drag the box into the middle of the screen as shown.
6. 

7. Next click on the Edit Tile Layer button.
8. 

9. You will see the following control panel.
10. 

11. All these button determine how you can change the tiles in the grid.  Let’s select the flood fill.
12. Next where it says Image – No Change, select that and choose the TilsetPuckaManImageMap.
13. 

14. When you do that the interface changes to show the first tile from the set as circled above.
15. If you want to access other tiles from that set you click on the Frame button as shown.  Pick the plain one.  It’s frame 41, the second last one as shown.
16. 

17. Click in the tilemap grid to fill with that piece.
18. 

19. Now we want to draft up the maze with one piece.  We will pretty it once we know where the paths are.  What you want to do however is tag the tiles with information now.  
20. First change to Frame 32.
21. 

22. Next select the None word in the Custom Data section by clicking and dragging across it to highlight it.  Then type in the number 10 over it.  This will tell the path finding system to not try to work a path through these tiles.  Then uncheck flip vertical and CHECK collision.
23. 

24. Now, selecting the Draw tool carefully draw out the walls of the maze like this.
25. As you are drawing notice the C symbol on the corner of the tiles.  This will not show in the game.  It just serves to remind you there is custom data on the tiles.
26. Also notice the blocky yellow corners.  These remind you there are collisions pasted onto these tiles.
27. Work carefully and save as you go.  You WILL be asked to save the LAYER as well.  Save that as level.lyr along the way (don’t name it the same as the level name as there seems to be a bug around that).
28. Here’s the map layout.
29. 

[bookmark: _Toc310968394]Detailing the maze.
Once you have the maze in place let’s go to the top left hand corner.  I’m going to show you how to get started, and then you can finish it on your own.
Here’s a handy lookup chart for you.  I got the tilemap this big by clicking on the frame button the grabbing the bottom right corner and dragging down.


1. The first tile we want on the left top corner, is a piece with a tiny corner in it.  This is frame 21.  Before you paint it in, change all the settings as shown.  This will keep the custom data and collisions intact while we paint it up.
2. 

3. The tile to the right should be 11
4. The tile below is 4.
5. 

6. Running it, it will look like this.
7. 

8. Put more 11’s across the top and 4’s down the side.
9. Now we want to paint the pathway.
10. The corner is 40.  The tops are 37 and the sides are 36.
11. 

12. Let’s do the middle island now, and after that you’re on your own.
13. The top section of the wall is done with tile 13.
14. The bottom section of the wall is done with tile 26.
15. The right top (in the lane) needs tile 42.
16. The one below the in the lane needs tile 36.
17. Below that on the bottom right corner in the lane it needs tile 39.
18. Then finally below the bottom wall use tile 38.
19. 

20. Now it should look like this.   Notice the drop shadow.  See what’s going on?  All the walls have a nice blue trim and the lane ways have a drop shadow in them.  Continue on now and finishing painting the details in the level.
21. 

22. The trick to finishing it off without continually changing tiles is to paste the same tile you have where it’s supposed to go.  So do all the tops, then the sides etc.
23. Also if you see a tile on the map you should have used, just use the eye dropper to sample it and the click on the Draw button to continue drawing with it. 
24. It should eventually look like this.  
25. 

26. With the grid/maze object selected but not in Tile Edit mode, under Scene Object change the position to 0,0 and the layer to 1.
27. 
.  
28. Also under Scripting name it mAZE (you’ll find out why).
29. 

30. Then under Collisions set as follows.  To uncheck Layers and Groups to check just one, click on None first.
31. 
 
32. Just a note here, that sometimes you need to clear all the tick boxes at the top and tick Receive Collision first (then the others) for it to work properly – you may find the player doesn’t collide in a minute unless you do.
Adding the player.
The player need to be animated.  
1.  Double click on the PuckaManImageMap under the Create tab->Static sprites and change to CELL, 32 x32 and save.
2. 

3. Now click on the Create an animation button, select the PuckaManimageMap as the materal and press Select.
4. Press the Plus button as shown to add all frames, change the Frame Rate to 14, and tick Ping Pong animation, so the mouth opens and closes.
5. 

6. Drag the Animated Sprite to the middle of the screen as shown.  The click on Edit and add Movement Behavior.  Place very specifically at 0,2.5 then set the size to 4 x 4. 
7. 

8. Under Scripting set as follows.
9. 

10. Scroll down to Collisions and set at shown.
Notice the collision layers.  These are set to only collide with object on particular layers and groups.

See that Collision Response is set to Sticky as well.


Try it now.  You will be able to move around the grid and not hit the walls.




[bookmark: _Toc310968395]Adding the power pills.
The little pills are what PuckaMan eats throughout the maze and all of them must be eaten for score and to complete the level.  These are static sprites that are named “Pill1”.
1. Drag a copy of the PacPillISmallImageMap on to the screen with Snap To Grid on.  You will need to manual drag it in place in the lane with the mouse to start with.  After that the snapping will make it move in place as required.
2. Under Edit tab, select Scripting and call it Pill1.
3. Under Collision select Send Collision. (all other settings are off)

4. 

5. Now copy and paste one then using the arrow keys on the keyboard nudge the pasted one into place so it’s in the middle of the lane as shown.  It’s 5 nudges between each pill.
6. 

7. Continue doing this until the maze is evenly spaced with pills as shown but leave spots as circled.  These will be the placed for the big Power Pills.
8. 

9. Because they are called Pill1 the “onCollision” method for the player will detect it as shown.
10. 

11. On line 282 if the object you just hit (represented by the word %dstObj) is named “Pill1” then the player has picked up a small pill.
12. On line 284 the pill (%dstObj) is deleted from the screen.
13. Line 285 accesses the ScoreText object (not added yet) and called the function addToScore on it, adding 1 to the players score.
14. Line 286 sets a local variable (means it will be forgotten next time around) to true so that this function being called (onCollision) doesn’t bother with other collisions once this one is done for efficiency.
15. Line 287 is a comment so you understand what the next pieces of code are supposed to do.
16. Line 288 gets sets a local variable (temporary) to point to the AudioHandler object (not yet added to the scene) to access the AudioPlayer behavior it contains.
17. So on line 289 we can then call the audio players function to play the “eatPill” sound at a volume of 1.0 (this can be any value from 0.0 to 1.0. 

[bookmark: _Toc310968396]Adding the Super Pill.
The super pill is almost the same as the small pill in placement however the code makes it do a whole lot more.  
1. Drag a copy of the PacPillI1ImageMap on to the screen with Snap To Grid on.  
2. Under Edit tab, select Scripting and call it Pill2.
3. Under Collision select Send Collision (all other settings are off)
4. Drag it into the 4 corners previously circled in red.  Make sure there are no small pills under them.
5. 

6. Let’s have a look at the collision code when you hit it.
7. 

8. You now know what lines 291 to 299 do because they are almost identical to eating the smaller pill.  However what happens next is that the Blinky ghost (we haven’t added yet) will change its animation to look blue – which is the “scared” animation.
9. Line 302 sets a global variable (one that is remembered for later use) to 0, and then following line sets another global to true to tell the path finding system that these ghosts need to run away from the player.
10. Line 304 sets Clyde (another as yet not added ghost) to look scared too.
11. Line 306 is a comment no interpreted by the code and is just for the programmers reference.
12. Line 307 gets a handle to the audio player as before but this time in line 308 it tells the %srcObj (your player) to remember this alarm sound played so it can be turned off when the pills effects wear off.  For now it fires off the alarm sound and tells it to loop.  It sets the volume of the sound to 0.6 so it’s not too loud.
Run the game now.  You will be able to eat the pills but nothing happens in terms of the feature we have seen in the code.  Let’s fix that now.
[bookmark: _Toc310968397]Adding Sound Effects.
You will probably remember that to add sounds we need to load the Audioicon and add the sound manager behavior to it.  It’s still the same this time. I have already coded the behaviors to fire off sounds.  So lets set it up and we can dissect a little bit.
8. Click on the Create image Map icon.  Load the AudioIcon.png
9. 

 
10. Drag the AudioIcon on to the scene above the main screen as shown (so it won’t be seen in game)
11. Click on the Edit tab and while the AudioIcon is still selected scroll down to Behaviors and add the AudioManager.  Then scroll down to Scripting and name it AudioHandler (all one word as shown)
12. 

13. Save the level and then run the game.  You will now hear sounds for eating the small and large pills.  The alarm will also sound when you pick up the big pills.  If the audio icon appears in the game drag it up a bit.
[bookmark: _Toc310968398]Adding the Score.
The score is essentially a text object we drag onto the scene and attach a behavior to.  It needs to be named as well.
1. Click on the Edit tab and scroll down to the “Other” section, to find the icon with ABC on it.  Drag it across onto the scene and put it up the top.  Immediately type in the words       “Score: 0”. 
2. The Edit tab will already be selected and you will be in TextObject mode.  Change the text size to 6, the Hide Overflow should be unchecked.
3. 

4. Now scroll down to Behaviors and add “Keep Track of Score”.
5. 

6. Finally we need to name it so scripts can use it.  Scroll down to Scripting and call it “ScoreText” as shown.
7. Save the level and run the game.  You will now score 1 for each small pill and 250 for the large pills.
[bookmark: _Toc310968399]Adding the path for the ghosts.
So far we’ve go the infrastructure for a game but we have no natural enemies to introduce drama to the game.  We’ll change that now.  The ghosts will use A* (A-star) to actively hunt you.  We need to do a few things in preparation though.  The ghosts will find their way through the existing maze but they won’t lock to the grid system like you do.  We need to make almost railroad tracks for them to follow so they stay in the middle of the lanes.
1. Create a new tile map and drag it over the top of the existing one.
2. Under the Tile Map setting under the Edit tab change the Tile Count to 90 x 60 and the Tile Size to 1 x 1.
3. 

4. Now press ESC and you will be able to rescale the tile map to the size of the game screen underneath as shown – it will snap as you drag the edges.  (Click on Edit Tile Layer again to see the grid)
5. 

6. While in the Edit Tile Layer section, change the brush as follows.
7. 

8. Now click on the Bucket Fill icon and fill the entire grid with this.  This will tell the A* path finding system not to look at these files for a path to the player.  You won’t be able to see the grid underneath so scroll down to the Blending section under Edit tab and change alpha to 100.
9. Now change the following Tile Editing settings to the following.  To change Custom Data to None you have to replace the work 10 with None.
10. 

11.  Change to the Paint brush and start drawing out a path over the dots for the ghosts to follow as shown.
12. 

13. Keep going until the entire grid is covered.  A quick way to drag straight lines is to hold the SHIFT key then drag a selection box on this inside of a line of tiles.  Release and that space will be filled with the current tile you are drawing with.
14. In the end your paths will look like this.
15. 

16. Once done, press ESC, go to the Scripting section and name it “mAZE2_forGhosts” (no quotes) – silly bug there in the version I wrote this with, so it has to be named this way for the scripts to work.  Save it and you will be asked to save the tilemap.  Call it “ghostmaze.lyr”.  Then go to the Scene Object settings for this and uncheck Visible (we can always access it again from Projects tab.)
[bookmark: _Toc310968400]Adding the ghosts.
The ghosts need to use a script to move around.  It’s another version of scripting control using what’s known as a class.  You remember adding the code in main.cs as below?  This preloads the scripts for you.  All you need to do then is drop the ghosts in, name them then add the class to their scripting.  I’ll show you how now (brown cow).


1. Click on Create tab and double click on the Blue static image sequence. 
2. Change it to CELL, 64 x 64 and Save.
3. 

4. Repeat for the Pink one and the Yellow one.
5. Now click on Create new animation.
6. 

7. In the Select Material window (below) double click on the GhostType1ImageMap and click on Select.
8. 

9. Now in the Animation Builder window (below), click on the Green plus to add all frames, change the frames per second to 10, cycle the animation and click on Save.
10. 

11. Repeat for the Pink and Green ghosts (however their frames per second is only 2 as they appear to be calm).
12. Now from the Animated Sprites section under the Create tab, drag the Pink one (who shall be named “Pinky”) to the maze and place her in the top left hand corner as shown.  Uncheck Snap to Grid and place precisely in the middle of the lane as shown.
13. 

14. Once placed, under Scene Object (under Edit) change the Size to width of 4 and height of 4.
15. Now scroll down to the Scripting section and this is where it gets a bit technical.  Change as follows (collision as well)
16. 

17. The technical part is the Class name “AIClass”.  This will access a file called AIClass.cs.  The other part Super Class is called “aStarActor” and this accesses a file called aStarActor.cs.  To cut a long story short, aStarActor has all the control to make the ghosts follow paths and manage all that stuff.  AIClass adds to that the ability for all that technical path finding stuff to work in the game PuckaMan.  It does stuff like look for the player, run from the player, kill the player.  Those sorts of things.
18. So now run it and watch what happens.  If all goes well the Pinky ghost will follow you around.  When they hit you the player die sound will happen and after a brief moment you will reset.  There are a few things missing like changing number of lives remaining, playing death anim etc but they are stil to come.
19. Now add the Green ghost in the same manner from step 12, but call it Clyde instead of Pinky in the Scripting options.  Also place Clyde top right in the maze.  

20. 


21. Running the game now, both Pinky and Clyde follow you, but occasionally Clyde will follow Pinky.  It’s the Actor.cs code if you are curious.  Also you can eat the big pills to eat the ghosts.

[bookmark: _Toc310968401]Adding number of lives.

We need to show the number of live on screen.  We’ve done this before in Space Attackers so it’s the same process.
1. Under Create tab, find the Static Images and drag a copy of the PuckaMan sprite to the bottom of the scene.
2. Add the “Handle Lives” behavior as shown.
3. Name it LivesManager in Scripting.
4. 

5. You don’t need to add 3 copies.  The number of lives is generated by the lives field in Handle Lives.
6. When you get hit, a life will be removed as shown.
7. 

[bookmark: _Toc310968402]Adding the death animation.
We need to animate the Puckaman death.  We’ve loaded the frames already, they just need to be animated.  
1.  Double click on the PuckaManDeathImageMap under the Create tab->Static sprites and change to CELL, 32 x32 and save.
2. 

3. Now click on the Create an animation button, select the PuckaManDeathImageMap as the materal and press Select.
4. Press the Plus button as shown to add all frames, change the Frame Rate to 15, and untick Cycle animation, then click on Save.
5. 

6. Run the game again and when you die the PuckaMan will play a nice animation before being reset.
7. 

[bookmark: _Toc310968403]Adding bonus fruit.
To encourage the player to move around there is bonus fruit to pick up.  Here’s  how to add it.
1. Find the banana and drop it somewhere in the scene.
2. Name it Banana (case is important)
3. Uncheck all collisions except Send Collision as shown.
4. 

5. Drop the cherry in the scene.
6. Name is Cherry (case sensitive)
7. Tick only the Send Collision.
8. 

9. Play the game now and you will receive bonus points for eating the food.
[bookmark: _Toc310968404]Finalising the game.
Once we eat all the pills or we die its game over.
1. Drop the GameOver sprite on to the scene.
2. Resize it to be bigger.
3. Under Scripting name it GameOver.
4. 

5. Got to Scene Object and uncheck Visible.
6. Now when you play the game, if you eat all the pills or lose all your lives it’s Game Over.

[bookmark: _Toc310968405]Challenges.
Display a different message if you win the game ie eat all the pills.  
In week 11 we’ll revisit PuckaMan to add a new level.





[bookmark: _Toc310968406]
Application #6:  Super EpicMan

EpicMan is based on Ghouls and Ghosts, a Platformer.  It was a jump, shoot and run scrolling game.  Check out this video.
http://youtu.be/qpqxNssTGak
(Skip to 1:30)
Here’s a game that was made with the Platform Start Kit as part of Torque.
http://vimeo.com/1054612


[bookmark: _Toc310968407]Getting Started.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session6.
2. Next go to the Resources folder for this unit, locate Session6 and paste that into the T2DSemester1 folder (files in folder, behaviors / common / gameScripts / gui folders as well. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  .  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.
[image: ]  
1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in SuperEpicMan. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session6.  So your final destination will be something like “E:/ T2DSemester1/Session6”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


As before first step is always to write a short description of a new game:

Deep in the caverns of Gnarls Reach a brave and ugly hero fights to get out.  Along the way he encounters evil monsters rabbits.  He can collect treasures along the way.

This forms what’s know as a functional specification.  It’s essentially human readable steps to cover the way a game plays out.  For our SuperEpicMan game, the functional spec is a about as complex as the PuckaMan game.
1. Load background, evil rabbit, sounds, player and items.
2. Create platforms and put collisions on them.
3. Create a player and add movement.
4. Bind the camera to the player.
5. Add pickups.
6. Add a win condition.
7. Add bad guys.
8. Fight bad guys.
SuperEpicMan will need a playerClass to allow the player to move around and a camera behavior to keep track of the player onscreen, so you need these files.  You would have copied over the behavior files as always, but you will have also copied the gameScript files.  You will find both resources in the Session 5 folder.  Refer to Session 1 on the Balloon Pop game if you don’t know what to do by now. 
1. From the E:\T2DSemester1\Session6 folder, cut and paste (or Move) the contents of the behaviors, gameScripts and gui folder from Session6 to here (E:\T2DSemester1\Session6\SuperEpicMan\game), overwriting any existing files.
2. 

3. Move up one folder on the right (your game folder) to E:\T2DSemester1\Session6, then cut and paste the “common” folder as shown to (E:\T2DSemester1\Session6\SuperEpicMan)
4. 

5. Create a new Torsion project as in Appendix 2 – the Base Directory should be (E:\T2DSemester1\Session6 \EpicMan)
6. Add these lines to game.cs.  This diagram will show you the code to add in (from Torsion), as well as where game.cs is located.
7. 

Let’s bring in the assets first.  I have made all the graphics for you this time.  Here’s how it’s going to look.



[bookmark: _Toc310968408]Adding the player.
Create the player sprite.
1. Click on the Create tab, Create new image map and load “spritesheet.png”.
2. Double click on the “spriteSheetImageMap” and change its Image mode to CELL and set the Cell Width and Height to 128. Then click SAVE.
3. 

4. Then click on the “Create a new Animation button”.
5. 

6. Select the “spriteSheetImageMap” source, then click on Select.
7. 

8. Let’s add the run cycle first.  Select the first 6 frame as shown by double clicking on each one from left to right.  Then change frame rate to 8, tick Cycle Animation and change name to PlayerRunAnimation – you must name all these as I have done otherwise the scripts wont work.  Then click Save.
9. 

10. Next we will do the Stand animation. Click on Create Animation again and select the “spriteSheetImageMap” source, then click on Select.
11. Next select all the frame shown below.  Change to 5 frames per second, cycle animation and name it PlayerStandAnimation.  Then click on Save.
12. 

13. Now we will create the Jump Up animation. Click on Create Animation again and select the “spriteSheetImageMap” source, then click on Select.
14. Next select the frame shown below.  Change to 30 frames per second, uncheck cycle animation and name it PlayerJumpUpAnimation.  Then click on Save.
15. 
16. 

17. Next we want to create the JumpDown animation. Click on Create Animation again and select the “spriteSheetImageMap” source, then click on Select.
18. Next select the frame shown below.  Change to 30 frames per second, uncheck cycle animation and name it PlayerJumpDownAnimation.  Then click on Save.
19. 

20. Finally we want to create the Attack animation. Click on Create Animation again and select the “spriteSheetImageMap” source, then click on Select.
1. Next select the frames shown below.  Change to 5 frames per second, BUT THIS TIME UNCHECK  Cycle Animation and name it “PlayerAttackAnimation”, then click on Save.  We need to have Cycle Animation unchecked so at the end of every attack we can detect it in scripts, affect the players health, then restart the animation manual.  It gives us more control.
21. 

In your Animated Sprites section it should look like this.


[bookmark: _Toc310968409]Creating the level.
Now we are going to load the background and drawn on collision boxes so the player can land on the platforms as if they were really there.  They aren’t, they are just part of the picture but we will tell the system were we want the platforms to be.
1. Create new image map and load “new_cave_bg.jpg”
2. Drag it into the scene and then go to Edit tab.
3. Under scene object, set its position to 0,0
4. Resize it to 230, 75 as shown.
5. 

[bookmark: _Toc310968410]Adding the collision maps.
We can now add the collision maps to the screen.  Collision maps in this case are merely rectangles with collision set up sitting in a Group.  
1.  Drag a Scene Object onto the scene around one of the platforms as shown.
2. 

3. Now you go to edit mode.  So resize the rectangle as shown.  It should be about half way across the path at the top and leaves a little space down the bottom.  The space at the top makes the player appear to walk in the middle of the platform.  The space at the bottom allows the player to jump from below without immediately colliding with it.
4. 

5. Under Scene Object, set the Group to 1.  We do this so there are a group of objects superficially set aside for platform collisions.  Good time to Save now.  Save the level as level1.t2d
6. 
 
7. Now we need to set up the collision response for it.  Scroll down to the collision section and set as follows.  Notice the collision groups down the bottom is only set to 0.  This is for the player.  To quickly set only 1 group, click on the None button and then click on 0.
8. 
9. 

10. Okay that’s one done.  Click on the object in the scene. Press CTRL + C to copy, the CTRL + V to paste.  Now move the new collision rectangle over the next platform.  You can use the arrow keys or click inside the box to move it into place.  It’s ready to go.
11. 

12. Repeat this process to cover all platforms.  Resize as required.  Finally do a bit one for the bottom of the screen.
















[bookmark: _Toc310968411]Adding the Player to the scene.
We can now drop the player in.  The player will collide with objects on Group1 and will have a world limit set to the extents of the screen but dodged in a little so they stay fully onscreen most of the time.
1. Drop in PlayerStandAnimation from the Animated Sprites section down in the bottom left hand corner.
2. 

3. Under the Edit tab, scroll down to Scripting and set the Name to “Player” and the Class to “playerClass”.  If you remember the game.cs file we changed in Torsion, you will remember this is the class we included in the code.
4. 

5. Change the world limits of the player by clicking on the World Limits button on the character as shown.
6. 

7. While in World Limit mode, edit to be like this.  Notice it’s a little short of the left the right and a little taller than the game world.  Press ESC to get out of that mode when you are done.


8. Under World Limits, under the Edit tab, set world limits to CLAMP.  This will stop the player for falling out of the world.  
9. 

10. Next set the Collision settings as follows.  Also pay particular attention to the Collision Groups, and make sure it only collides with 1.  Remember to clear the group, press None first, then click on 1.
11. 


[bookmark: _Toc310968412]Setting the Players Collision mask.
Normally the Player collides uses a bounding rectangle around the sprite to collide with.  We want a more accurate version of this.  For Platformer games a “pill” shaped collision mask works better.  
1. We can edit the collision mask by click on the button shown, after selecting the player sprite.


The collision editor allows you to add points and delete them, and move the points around.  
1.  Grab point 0 and move it to the top of the head.
2. 

3. Move points 1,2 and 3 as shown.
4. 

5. Click on Add point once.  A red point appears in the middle.  Drag it to the point as shown.
6. 

7. Add another point and move to the position as shown below, then hit Save.
8. 


[bookmark: _Toc310968413]Setting the gravity.
Being a Platformer, the player must be able to jump.  If the player jumps, they must be able to fall.  
1. Click on the player, go to the Edit tab and under Physics, make sure Gravatic is ticked, and set to 4.0
2. 


[bookmark: _Toc310968414]Setting the Background render layer.
To make sure the background always gets rendered behind everything else click on the background and under Edit->Scene object, change the Render Layer to 30 as shown.


[bookmark: _Toc310968415]Following the player with a camera.
Scrolling games typically have a larger game world than can fit on the screen.  This game is no different.  So we need to make the camera follow the player as they move around the world. 
1. From the Create menu under Other, drag a Scene object over the pl
2. 

3. Next we need to move the Scene Object directly over the player so it is centred and then click on its Edit World Limits button.
4. 

5. You need to make the Scene Object match the exact edges of the world this time.


Now we need to assign a behavior to the Scene Object to make it the Platformer Camera.
6. 

Press ESC to end World Limit and while still having the scene object select go to Edit tab->Behaviors and add Platformer Camera to it.  Also scroll down to World Limits and set to CLAMP – this will lock the camera to the world limits you just set 
7. You will notice you have a few options to set in the Platform Camera settings.  For now the target needs to be the player, the viewLimit needs to be ticked, as well as the trackHeight checkbox.  

Refer to Appendix 3 for more information on the other settings.
Save and run now.  If you’ve done everything right, the player will now be able to jump around the level, show the relevant animation for each pose and the camera will following him.



[bookmark: _Toc310968416]Adding the enemy.
The enemy needs to have all the animations loaded, just like the player.  This enemy is simplistic and just hacks away at your health if you get close.  Let’s add the graphics and animation first.
2. Click on the Create tab and click on Create new image map.  Load “bunnysheet.png”.
3. Double click on the Static Sprite and set to CELL, 128 x 128 and save as shown below.
4. 

5. Next click on Create new animation.
6. 

7. From the Select material window click on the bunnysheetImageMap as shown and click on Select.
8. 

9. We’ll create the EnemyRunAnimation (spell it like this up next).
10. 
Double click on all the frames highlighted in red below, set frame rate to 6, tick Cycle Animation and name it “EnemyRunAnimation”, then click on Save.
11. Next we’ll create the EnemyStandAnimation, so click on Create Animation, click on the bunnysheetImageMap (as before) and click on Select.
12. 
Double click on all the frames highlighted in red below, set frame rate to 6, tick Cycle Animation and name it “EnemyStandAnimation”, then click on Save.
13. Next we’ll create the EnemyAttackAnimation, so click on Create Animation, click on the bunnysheetImageMap (as before) and click on Select.
14. Double click on all the frames highlighted in red below, set frame rate to 6, BUT THIS TIME UNCHECK  Cycle Animation and name it “EnemyAttackAnimation”, then click on Save.  We need to have Cycle Animation unchecked so at the end of every attack we can detect it in scripts, affect the players health, then restart the animation manual.  It gives us more control.


[bookmark: _Toc310968417]Putting the enemy into the scene.
The enemy can be place and enable by following these instructions.
1. Under Animated Sprites, drag the EnemyStandAnimation to just in front of the player as shown, and under Edit tab, add the Enemy Handler behavior.
2. 

Run the game now.  When you get close, the enemy will attack you.  He doesn’t do any damage right now because we have to link the GUI health to the attack.  Let’s do that now.
[bookmark: _Toc310968418]Controlling Score, Health and FirePower.
You will have noticed that Score, Health and Firepower are on the screen when you play the game but up to now do nothing.  You may have noticed that they always remain in the same spot on the screen regardless of whether you move across the screen.   Some on you may be aware that this is no easy feat.  Others may have not even blinked and expected this to happen.  Either way, this is the convention of the side-scroller, that the health, score and weapon info must be show regardless of where the player is in the world.  
Previously we dragged a text element to the screen, named it ScoreText and assigned a HandleScore behavior to it.  This time, the score is actually stored in the GUI (Graphic User Interface) under gui/mainScreen.gui.  The score, health and firepower are still called ScoreText, HealthText and FireText.  If you open the Torsion project (refer Appendix 2 for this – don’t need to) you will see this.


[bookmark: _Toc310968419]Adding score.
We can still access those text elements but we need to add an offscreen object to apply scripts to.
1. Under Create tab, click on Create new Image map and load “guiElementIcon.png”.  Drag out a copy to the top upper screen (not visible during play).  Add a “Keep Track Of Score” behavior to it from the Edit tab while selected.  Under Scripting name it “ScoreGUIHandle” so the scripts can call it.
2. 


[bookmark: _Toc310968420]Adding Health.
1. Drag out a copy to the top upper screen (not visible during play).  Add a “Keep Track Of Health” behavior to it from the Edit tab while selected.  .  Under Scripting name it “HealthGUIHandle” so the scripts can call it.
2. 

[bookmark: _Toc310968421]Adding FirePower.
1. Drag out a copy to the top upper screen (not visible during play).  Add a “Keep Track Of Fire” behavior to it from the Edit tab while selected.  .  Under Scripting name it “FireGUIHandle” so the scripts can call it.
2. 

Now run it again.  When the Bunny hits you, your Health will go down.
[bookmark: _Toc310968422]Attacking the Enemy – Adding Pickups.
Pickups or POWs are another convention of the Platformer game.  Players will often pickup gold, weapons or damaging objects.  
The player has an attack animation which a human-fireball attack.  However it needs power.  If you try to press Z right now the player will NOT attack.  They need to pick up FIRE fuel.  Fire fuel comes in a green glass jar.  We need to add that now.
1. From the Create tab click on Create new image map and load “firePotion.png”
2. Drag a copy onto a platform as shown, and under Behaviors add “Sets A Score”, setting it to 150 and “Collision Handler”.
3. 

4. Scroll down to Scene Object and set Group to 1 (remember the Player only collides with Group 1 object) and in scripting calling it “FirePotion1”.  
5. 

6. Under Collision tick Receive Collision, and Callback.
7. The scripts support 2 more so place two more (with the settings above – you can just press CTRL C, CTRL V then move the copy and rename), and name them “FirePotion2” and “FirePotion3”.
[bookmark: _Toc310968423]Adding Sound.
Let’s add the sound handler now we have more things happening in the game.
1. Under Create tab, click on Create new image map and load “audioIcon.png”.
2. Drag it into the scene next to the three Text handles off the top of the screen as shown and under Edit tab->Behaviors add “Audio Handler” and under Scripting name it “AudioHandler”.
3. 

Run the game now and you will not only be able to pick up the fire potions, but you will get score, your FirePower will increase and you will be able to burst into flames when you press the Z key (stay still to see animation).
[bookmark: _Toc310968424]Adding the Exit.
Most platform games have an exit.  You tend to be searching for one, and collect stuff on the way.  The GUI mainScreen.gui already has it defined, we just need to add a condition for when we find the exit.  There’s an exit doorway graphic we can load and collide with.
1. From the Create tab, select Create new image map and load the “CastleWindow1.png”.  Go the right-most of the scene and place it at the top as shown.
2. 

3. Under the Edit tab->Behaviors, add Collision Handler.
4. 

5. We need to set it’s collision, so under Scene Object set it’s Group to 1, and also set it’s layer to 29 so everything except the background it drawn ontop of it.
6. 

7. Under Scripting call it “Exit” and under Collision check on Receive Collision, and Callback so it will call onCollision in scripts.
8. Finally we want to see the ExitFound1.png, so load that under the Create tab->Create new image map.  This will have the effect of copying it to game\data\level\images where scripts expect to find it.
Running it now you will be able to run to exit and an Exit Found message pops up on the screen.
[image: ]
[bookmark: _Toc310968425]Challenges.
While this looks good, it’s not the most exciting game, because it just shows you how to start on a Platformer.  Here’s what you should try to add.  All of these required scripts to change so if you aren’t up for the challenge come back here after Session 10 and try it.
1. Enemy health.  When an enemy’s health goes to 0, kill it off.  Also add more bad guys.
2. Player death.  When the player’s health goes to 0, remove 1 life – life systems are done in Space Attackers and PuckaMan.
3. Health power-up.  There’s a heart symbol in the folder.  See if you can add this as a new power up.
4. Score power-up.  There’s a 100 symbol in the folder.  Allow player to pick it up.




[bookmark: _Toc310968426]Application #7:  Scrolling Background

If you are working on a side scroller then you need to understand how to implement parallax scrolling.  This is the pseudo-3D effect where images are layered ontop of each other and moved along the screen at different speeds to simulate depth.  We see in stereoscope with our perception of depth stemming from the concept that more distant objects are smaller, and when we step sideways they move slowly away, compared to objects that are closer, which move faster away.
[bookmark: _Toc310968427]Getting Started.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session7.
2. Next go to the Resources folder for this unit, locate Session7 and paste the contents of that into the T2DSemester1 folder. 
Move the behaviors folder.
1. From the E:\T2DSemester1\Session7 folder, cut and paste (or Move) the contents of the behaviors into E:\T2DSemester1\Session 7 class\ScrollingBackground\game\behaviors
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.
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1. Click on the Create pane to get started.  
2. The next screen you will see is this (below).  In the Name box, type in ScrollingBackground. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session7.  So your final destination will be something like “E:/ T2DSemester1/Session7”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


[bookmark: _Toc310968428]BugFix:
There’s a bugfix for the code you need to make for your install of Torque.  It is noticed when you save a game with scrollers in it and you load it another time.  You end up not being able to see the scrollers when you run the game or they are grossly oversized.  Here’s the fix.
1. Setup a new project called ScrollerBackground in Torsion as explained in Appendix 2.
2. In the common folder, find levelmanagement.cs and scroll down to around line 64, hit enter to insert a new line and add the code as shown below.  Save it.  Now the problem goes away – but you will have to run it from Torsion using CTRL+F5.

[bookmark: _Toc310968429]Setup the background.
1. Click on the Create tab and then click on Create new image map.  Load  “sky.png“, drag into  the scene (from State Sprites) and centre.  Resize to fit the camera. 
2. Under Edit tab-> Scene Object, set layer to 30 (see below).  The layer system is the easiest way to set objects drawing order.  The higher the number the further back it is.


3. Click on the Create tab, click on Create new image map and load the “CloudBank.png” graphic.  This time however drag the Scroller version of it onto the stage rather than the normal image.


An important note is when you import images intended for scrolling – make sure they are a power of 2 on both dimensions.  So image sizes of 512 x 128, or 64 x 64.  Any numbers such as 8, 16, 32, 64, 128, 256, 512, 1024.  Otherwise you will end up with an annoying white space in them.
4. Now resize it to fit the width of the screen and no t look too stretched.  Then click on the Edit tab and change its x scroll speed to 5 as shown.  It will start scrolling for you.  
5. Scroll down to Scene Object and change its layer to 5.


[bookmark: _Toc310968430]Building up the scene.
So now we know how to scroll let’s build the scene up.  We need to load all the objects and then we’ll set the scroll speeds.
1. Load in the “Background1.png”, drop the Scroller version of the graphic into the scene, resize to fit the bottom half and set it to layer 2, X scroll speed 7.


2. Next load in the “Hill1.png” image map, drop the Scroller version of the graphic into the scene, stretch to fit the width of the screen and set them to layer 3 which makes it appears behind the grass.  Set X scroll speed to 4.


3. Drag in 2 more sets of the CloudBank and set them to layer 6 and 7, scroll speed 2 and 3.  Make the first cloud on layer 6 a little smaller, and then one on layer 7 to be smaller again. 


4. Drop the cloud on layer 7 down a little.


5. 
The last 2 cloud layers need to repeat, so for layer 6 under Scrollers set Repeat X to 2, and for layer 7 set repeat to 3, and stretch them out to be the width of the window.  
6. Set the X Scroll Speed for layer 6 to 2 and for layer set the X Scroll speed to 1.
7.  Then load “Grass.png” via the Create tab->Create image map button, and load the “Tree1.png” the same way.
8. Drag the Scroller version of the tree and grass into the scene.  Under Edit tab->Scene Object set the grass to layer 0 and the tree 1 layer 1.


9. The tree needs to be repeated 4 times under Scroller->Repeat X, and stretched to fit the scene.  Set its X Scroll Speed to 7.


10. Finally repeat the grass 10 times, stretch to fit scene and scroll at speed of 8.
There you have it.  A scrolling view perfect for a shooter.
To see it in action flick back and run it from Torsion using CTRL+F5 (because of the bug)

[image: ]
[bookmark: _Toc310968431]Improvement.
I don’t like the repeating trees.  So you can remove them and place single trees this way.
1. Remove the tree scroller object from the scene.
2. Drop in the static image (not the scroller) of the tree – only one copy.
3. Add the World Wrap behavior under Edit tab->Behaviors while having the tree selected.
4. Scroll down to Physics and set the X velocity to 7.
5. Wave your mouse over the tree and select the “Change the world limits” button as shown below.
6. 

7. When setting the world limit make sure the grey box below extends beyond the edge of the screen so the tree will go off the screen, wrap around off screen the scroll on to the screen the other side.   Press ESC when you are finished.


8. Now it loops but only shows 1 per screen now.


[bookmark: _Toc310968432]Challenges.
There’s a flying pig, an angry bird, a bird splat, a 100 score, a blast, a bullet and an egg in that folder too.  See if you can make a shooter game with what you’ve learned.



Here’s some hints.
1.  Firing is done in Space Attackers.
2. Explosions are done in Space Attackers.
3. Spawning the egg is similar to creating the POP word in Balloon Pop.
4. You know where to get the scoring functions from.
5. Start the angry birds off screen and like the trees set their world limits to extend beyond the screen.
6. When one gets shot, like the balloons move it back off the screen again, add some score and spawn an explosion.  
7. Occasionally drop an egg.
8. Picking up the egg increase the fire rate.


[bookmark: _Toc310968433]
Application #8:  Starfield

Another implementation of parallax background can be useful for creating a scrolling starfield.  We can implement a similar method to the previous application, so a lot of the information presented in this will skim over the step assuming you have completed application # 7.  So refer to that if you get lost.  In this application we will add feedback from the user to control the starfield.


[bookmark: _Toc310968434]Getting Started.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session8.
2. Next go to the Resources folder for this unit, locate Session8 and paste that into the T2DSemester1 folder. 
This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.   If you can’t see this pane, and have launched the previous project, click on New -> New Project and proceed to step 2 or following step 1 if you see this pane.

[image: ]  
1. Click on the Create pane to get started. 
2.  The next screen you will see is this (below).  In the Name box, type in Starfield. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session8.  So your final destination will be something like “E:/ T2DSemester1/Session8”. 
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.


Start by loading all the assets at once this time, which can be done by CTRL and left clicking to add all them together in one go.
Now that you have them all, do the following.
1. Drag in the purple background as a static image.


2. 
Drag in the SmallStarImageMap map as a scroller, and set it’s scroll speed to -5 on the Y.  Hold CTRL and size it so it’s as wide as the purple screen but longer
3. Repeat for MediumStarImageMap, resize the same but set it’s speed to -3.
4. Repeat for BigStarImageMap, resize the same but set its speed to -1.
5. Save it as level.t2d.
6. Run and you should have an awesome scrolling starfield.


[bookmark: _Toc310968435]Challenges.
You’ve got the space ship and aliens, alien and player bullets and explosions.  Go ahead and make a simple shooter using what you have learned from SpaceAttackers.
· Make all the aliens move down the screen (change their y momentum in physics).  
· Use the WrapWorldLimit behavior to loop aliens around if they hit the bottom of the screen.
· If an alien gets shot, just reset it’s position to the top of the screen along a random point (see WrapLimitRandom)



[bookmark: _Toc310968436]Application #9:  Simple RPG

RPG’s are a popular 2D game that represent a big challenge when authoring interactive sequences.  T2D is more than capable of doing this however you must be careful with the depth in which you get into, as you will only have 10 weeks of 2.5 hours to finish this kind of game if you choose to do this.
[image: ]
(C) Crimson Gem Saga.


[bookmark: _Toc310968437]Getting Started.

1. You are using your hard drive with a folder on it called T2DSemester1.  Now make another folder inside that called Session9.
2. Next go to the Resources folder for this unit, locate Session9 and paste the contents of that folder into the T2DSemester1/Session9 folder. 
Start Torque. This is what the screen looks like when you open the PC version of Torque 2D for the first time.  If you have previously created a project and the Load Last Project on Start-up button was checked you may not see this scene as it will just straight into the main project.  If you can’t see this pane, and have launched the previous project, click on File -> New Project and proceed to step 2 or following step 1 if you see this pane.

[image: ]  
1. Click on the Create pane to get started.  The next screen you will see is this (below).
2.  In the Name box, type in SimpleRPG. Click on the browse button circled and navigate very specifically to YOUR hard drive, saving it to a folder called T2DSemester1\Session9.  So your final destination will be something like “E:/ T2DSemester1/Session9”.    Click on Open.
3. Tick the “Copy Game Executable to Game Path” checkbox and click on the Create button.



[bookmark: _Toc310968438]Add behaviors, common and gui folders.
As before with every game, once the game folder is established we need to copy over the folders required to run the behaviors and handle the gui.
1. From the E:\T2DSemester1\Session9 folder, cut and paste (or Move) the contents of the behaviors, gameScript and gui folder from Session9 to here... see below as well. (E:\T2DSemester1\Session9\SimpleRPG\game), overwriting any existing files.



[bookmark: _Toc310968439]Copying common to the game folder.
Common contains some font gui information that the game needs.  
1. From the E:\T2DSemester1\Session9 folder, cut and paste (or Move) the contents of the common folder from Session9 to here... see below as well. (E:\T2DSemester1\Session9\SimpleRPG\), overwriting any existing files.




[bookmark: _Toc310968440]Generating assets.
I’ve found a great site to generate all the stuff you want to prototype and rpg.  It makes perfect little characters for you.  It’s like a costume / character builder.  However if you don’t want to do this skip to “Importing Characters”.
http://charas-project.net/charas2/index.php
Go to the website and use the settings and buttons to select in this order to build up each character Lecturer should demonstrate one ...
1. Character type
2. Body
3. Face
4. Dress
5. Hair
6. Items


7. Once you’ve exported it, bring it into to Photoshop, using the Magic Wand and delete the green colour to make it transparent, and then save.


Save the sprites into the “E:/ T2DSemester1/Session9” folder and use these settings to set up the sprites.  
You need to make the following characters (unless you want to use mine).
· character.png
· enemy1.png
· nun.png
· monster1.png
· soldier.png
· wizard.png
· zombie.png
[bookmark: _Toc310968441]Importing Characters.
This next phase skips a lot of detail about creating sprites because you should know this by now.  In this example below I am setting up the Nun, but do this for all characters (see complete list above).  Follow these steps for all characters.  You can CTRL click when loading images to load all of them at once.
1. Create tab->Create image map (multiple select using CTRL will mean you can just then do step 2 for all if you choose).
2. Double click on static images to make into cell.   They are all 72 x 96



[bookmark: _Toc310968442]Player Animations.

Next you need to make animation sets for them.    We’ll do the player first.  Then repeat the process for the others yourself.
The animation are using set names.  Replace the word character with Nun, Player, Soldier etc but the keeps the end part.  So when doing the Zombie, characterUpAnimation is now ZombieUpAnimation.
· characterUpAnimation 
· characterDownAnimation
· characterLeftAnimation
· characterRightAnimation
· characterIdleAnimation
Replace the word character with the name of each new character so NunUpAnimation for example.    For the player we’ll just stick with character as the name for our player – but make sure you change the others as you do them.  
1. Click on the animation button.


2. Select the characterImageMap 


3. Next DOUBLE CLICK ONCE on each of the following images.  But look at this first.  If you add the wrong frame drag it away to delete it.


4. Okay so do the following images now.  Notice the second image is again added at the end to create a sequence of 4 images.  Set the frame rate to 5, and call it characterUpAnimation.


5. Click Save and repeat from step 1, this time using these frames below.  Frame rate 5 and call it characterRightAnimation.


6. Repeat and use these images at frame rate 5 for characterDownAnimation.


7. Repeat and use these images at frame rate 5 for characterLeftAnimation.


8. Finally do the characterIdleAnimation but just use this frame.



[bookmark: _Toc310968443]Background.
The basic floor of the world is going to be a large plain of grass.  We’ll use a tilemap for this so...
1. Under Create tab->Create image map and load “grass1.png”.
2. Still in the Create tab scroll down to Tilemap and drop one in like this from the bottom of the Create menu.


3. Release the mouse button and you’ll see a grid like this below.  Change the size to 50 x 50 and 5 x 5 on the right.  Then click on the “Size Object To Layer” button.


4. Now press ESC to get out of that editing mode and then you will be able to drag it to the top left.


5. We will now fill the tilemap with the grassImageMap we loaded.   While the object is still selected, click on the Edit Tile Layer button.


6. Select grassImageMap from the Image section as indicated below and then from the special toolbar as shown below, pick the Bucket then click on the tilemap on the left to fill.


7. Finally with the tilemap still selected, under the Edit tab select Scene Object and change the layer to 3 so it gets drawn under everything.


8. Now click on save.  It will probably ask you save your level (t2d) and your layer (lyr).  DONT name them the same.  Save level as myLevel1.t2d, and layer (the tilemap) as myTileMap.lyr otherwise you will encounter an nasty bug where it gets the two confused.
[bookmark: _Toc310968444]Player control.
Now we have some ground we can get the player to walk on it.  
1. From the Create tab, drag the idle player from Animated Sprites, the click on the Edit tab and add the Movement Behavior drop down in Behaviors.


2. Scroll down to Scripting and name them Player.
3. 


[bookmark: _Toc310968445]Controlling screen size.
When we add the GUI or the onscreen displays they are designed to a specific resolution.  Any other resolution (screen size) with introduce clipping of the image or gaps around the image.  To set the preferred screen size of the game follow these steps.
1. Click on Edit->Preferences in Torque.


2. Click on the Option tab.
3. Change the resolution to 800 and 600.


[bookmark: _Toc310968446]Onscreen text.
I have a standard GUI create for you for the information about the player to appear onscreen.
1. Drop in a T icon (“guiElementIcon.png”) as shown from the static images, and then add the Behavior “InfoWindow” as show.  Put the T above the screen boundary as we don’t want to see it, but just use its behavior.


2. Scroll down to Scripting and name it “InfoWindowHandler”


3. Hit play, and save your level and layer.  You should see this and be able to walk around.


Notice the Welcome message.  There is a behavior called InfoWindow that has a function called setText and you can pass anything to it.  This will be useful for dialog and environment messages such as “you can’t open that door”.
However you can walk off the map so let’s fix that.
[bookmark: _Toc310968447]Clamping the world limit of the player.
The player can be stopped by setting the world limit to be the extent of the map.
1. Select the player.
2. Wave your mouse over the player and select the World Limits menu button.


3. Set the world limit cover the entire tilemap as shown below.


4. Press ESC then scroll down to World Limit and set to CLAMP as shown below.


[bookmark: _Toc310968448]Torsion setup.
Create a new Torsion project referring to Appendix 2 to prepare for the next steps.
While in Torsion, if you look at the “SimpleRPG\ game\behaviors\infoWindowControl.cs “file it looks like this.


See the default message in the onAddToScene method circled above?  Then there is another method that says setText below onAddToScene.  This is the entry to write anything on the screen.  We’ll do that soon.  First let’s go back to Torque and get the camera to follow the player.
[bookmark: _Toc310968449]Camera follow.
This is similar to the way the Platformer game was working.
1. Drop a scene object over the player


2. Next add the platformerCamera behavior to it, and select the following settings.


3. Now change the worldLimit of the camera object to the entire map by waving your mouse over the scene object to bring up the menu as below.   Remember you are editing the scene object not the player object.


4. Set the world limit to cover the entire tilemap.  Roll the mouse wheel to zoom out if you need to.



5.  Press ESC then change the World Limit mode to CLAMP.


6. Then select the player, and set their world limit to a bit smaller than the entire world.  Press ESC.


7. Finally change the World Limit mode to CLAMP.


8. Save it and run.  The camera will follow the player, and will stop the player at the edge of the maps.
[bookmark: _Toc310968450]Player Collision Mask.
The player has a box around them for a collision mask.  Let’s make it a bit more exact.
1. Click on the player and wave your mouse over to bring up this menu.  Select the collision mask button.


2. Change the mask (refer to Super Epic man if stuck) to look like this.


3. Press SAVE and then edit the Collisions for the player like this.


[bookmark: _Toc310968451]Entities
Strange word, what does it mean?  An entity is anything in the world the player interacts with.  In RPG’s we have these kinds of interaction.
1. An info item like a sign to read or an NPC that just talks.
2. An inventory item is something the player can pick up and use.  Often these items are required to move onto a new part of the world, like a key will open a door.  Some items are quest items and are required to advance the information an in game character has for the player.  Some items instantly regenerate health or add gold.
3. An NPC – a non-player character, is an entity that can represent an info item and in this context they are either passing on information, chatting about the world to give you clues or are characters that want something, which then invokes a quest.  NPC quest characters will often have more info which can only be unlocked when you give them an item.  Other NPCs are only there to fight you.  Some NPC’s can sell you items and so their inventory is passed on to you when you click on one of their items and you exchange gold.  This item then goes into your inventory.
4. An environment object, like a tree or rock which is impassable or lava or water that will inflict damage instantly.
All of these entities are the same; just some do more than others.  Its useful then to make a behavior that handles all these situations, which we will write.  We need to break down the things it can do and the code them up.  When written (coded), we can simple drop a sprite on the map, add the behavior to it, tick some boxes and it works as designed.
[bookmark: _Toc310968452]Entity functional specification.
Here’s the plan for the behavior (or functional specification).
1. Info item/Info NPC – Tick to allow information to show in the window – either a sign or an NPC that give information.  An okay button will be added as well to advance information if present.  The function to call this say(“Something”)
2. Inventory item 1 – instant – adds gold or health (positive of negative) to player and disappears.  It could be a goblin stealing money, or a health potion for example.
3. Inventory item 2 – stored – when touched it goes into players inventory (which is another screen showing a maximum of 6 items)
4. Inventory item 3 – saleable – when player clicks on the BUY button it is added to players inventory, but reduces players gold.
5. Use item 1 – the player needs the tagged item to transform the state of this item.  An NPC has a lock on the info it shows.  A quest item required by this NPC will open its next bit of dialog, and can give the player a tagged inventory item instantly (see above)
6. Use item 2 – the player needs the tagged item to transform the state of this item.   This opens a door making it passable, or removes a hidden wall or trap.  (To be added)
7. NPC 1 – an entity with either one or more info texts that owns an inventory.  inventory are basically their store and you can buy items from their inventory.
8. NPC 2 – an entity that will fight the player.  During combat a special event happens and if the players defence is greater than the enemies attack the enemy is removed.  After one combat round the player goes back to normal and can move away or approach the enemy.  The enemy has defence, attack, and one drop item, usually it’s weapons or an item above.
Use these numbers to define the TYPE when added an object.  The code will know what to do with it.  Let’s get this adventure started!
[bookmark: _Toc310968453]Environment.
I’ve created a nice looking tree so go ahead and paste a path of adventure for the player.
1. Create tab->Create image map and load “tree2.png”.
2. Roll the mouse wheel back to zoom out on the level.
3. Draw a tree across, and resize as you feel appropriate.
4. Click on the Edit tab and under Scene Object change the layer to 2 so it gets drawn under the player.
5. Under collisions set to Send Collision.


6. Next we need to set the collision mask.  Wave your mouse over the tree to bring up this menu.


7. Then like the Super Epic Man adjust the mask.  If you get any red points click the button below to fix the mask.


8. You mask should look like this.


9. Now copy and paste that specific tree many times to make your path and environment.  
10. You may have some layering issues like this.  The tree should be behind but it was pasted afterwards.  Press the Backward/Forward buttons to fix.
11. BEFORE:


12. AFTER:


13. Continue until you have something like below.  For now we need a clearing and a path to another clearing.


14. Save it and walk around.  You should not be able to pass the trees.


[bookmark: _Toc310968454]Add an info item – Type 1.
At the beginning of a quest the lonely warrior will often be walking through a forrest and find a sign that explains where they are.  Let’s do that.
1. Create tab->Create image map and load “sign.png”.
2. Drag a copy into the scene near the player.  Resize to suit.
3. Add the Entity behavior to the sign.
4. Change the description to “An informative sign” – you wont see this in game.
5. Change the info1 to “Welcome weary traveller” – this will come up in the info window.
6. Change the type to 1 as per the functional specifications we looked at before ie ...

Info item/Info NPC – Tick to allow information to show in the window – either a sign or an NPC that give information.  An okay button will be added as well to advance information if present.  The function to call this say (“Something”)



7. Select the Scripting and Collisions for this sign and set as follows.


8. Now run the game.  When you collide with the sign the info Windows shows the message to the player.




[bookmark: _Toc310968455]Inventory Item Type 2 - Instant.
Inventory items are items you collect, drop, sell and equip to enhance your adventures.  Let’s put one in now.
1. Create tab->Create image map and load “healthInstant.png”.
2. Drag a copy into the scene near the player.  Resize to suit.
3. Add the Entity behavior to the sign.
4. Change the description to “Instant Health” – you won’t see this in game.
5. Change the info1 to “You feel much better!” – This will come up in the info window.
6. Change the type to 2 as per the functional specifications we looked at before ie ...

Inventory item 1 – instant – adds gold or health (positive of negative) to player and disappears.  It could be a goblin stealing money, or a health potion for example.

7.  In the addHP box type in 50 – this is the health we will get.
8. In Scripting name it Instanthealth
9. In Collisions set as shown below.
10. 

The event on the collision of the instant health sends a message to the GUI to update the health and keep track of it.  We need to create a health manager object off the scene to deal with this.
1. From the static images drag out another T icon at the top of the scene.
2. Add the “Keep Track Of Health” behavior to it.
3. In Scripting name it HealthManager.
4. 

5. Save and run the game.  When you make contact with the health it will disappear, your health in the GUI will increase by 50 and the info window shows a new message.
6. 

[bookmark: _Toc310968456]Challenge:
The mana potion will increase your mana.  Repeat the above steps but load the “manaPotion.png” and set up as above.  It will need to be called Mana1 in Scripting; you’ll need a ManaManager T icon as well.  Give it a go.  See your Lecturer if you get stuck.
[bookmark: _Toc310968457]Instant Item Gold.
Gold is an instant object but needs to be controlled with a gold manager so you get to keep the gold.
11. Create tab->Create image map and load “gold.png”.
12. Drag a copy into the scene.  Resize to suit.
13. Add the Entity behavior to the gold.
14. Change the description to “Gold” – you won’t see this in game.
15. Change the info1 to “Your fortune increases.” – This will come up in the info window.
16. Change the type to 2.
17.  In the addGP box type in 100 – this is the gold we will get ( don’t put it in gold ).
18. In Scripting name it Gold1
19. In Collisions set as shown below.
20. 

The event on the collision of the instant gold sends a message to the GUI to update the gold and keep track of it.  We need to create a gold manager object off the scene to deal with this.
7. From the static images drag out another T icon at the top of the scene.
8. Add the “Keep Track Of Gold” behavior to it.
9. In Scripting name it GoldManager.
10. 

11. Save and run the game.  When you make contact with the gold it will disappear, your gold in the GUI will increase by 100 and the info window shows a new message.
12. 


[bookmark: _Toc310968458]Adding Sounds.
There are 3 events so far that happen that create sounds you haven’t been able to hear yet, because the audio handler is not in place.  
1. Drag another T icon next to the others off the scene.
2. Add the Audio Handler behavior to it.
3. In Scripting name it “AudioHandler”.
4. 

5. Save and run the game.  You will hear “welcome” when game starts and two new sound when you touch the sign and pick up the health.

[bookmark: _Toc310968459]Inventory Item Type 3 - Storage.
The other type of inventory item is one that is stored for later use.  Let’s implement that now.
1. Create tab->Create image map and load “Sword1.png”.
2. Drag a copy into the scene near the player.  Resize to suit.
3. Add the Entity behavior to the sign.
4. Change the description to “A Sword : Attack + 10” – you won’t see this in game.
5. Change the info1 to “The scourge of this land won’t stand a chance.” – This will come up in the info window.
6. Change the Type to 3 as per the functional specifications we looked at before ie ...

Inventory item 2 (type 3) – stored – when touched it goes into players inventory (which is another screen showing a maximum of 6 items)

7. In the attbuff (Attack modifier) box type in 10 – this is the effect of holding this weapon to our attack rating.
8. In Scripting name it Sword1.
9. In Collisions set as shown below.


The event on the collision of the sword sends a message to the GUI to update the health and keep track of it.  We need to create an attack manager object off the scene to deal with this.
10. From the static images drag out another T icon at the top of the scene.
11. Add the “Keep Track Of Attack” behavior to it.
12. In Scripting name it AttackManager.


The type 3 item is special in that you have the CHOICE to add it to your inventory.  We need to add some buttons to enable this choice.
13. From the Create tab->Create new image map and load both “Take.png” and “Leave.png”
14. Save and run the game.  When you make contact with the sword two icons appear; Take and Leave.  


15. Also the info window will show the message.  


16. Clicking on Leave removes the buttons and you leave the sword there.
17. Clicking on Take will show a new message, you will see the sword appear in your inventory and an upgrade to your attack rating will appear as shown below.



[bookmark: _Toc310968460]NPC2  - Enemy.
This kind of NPC or non-player character will attack the player.  You attack by running into them.  They will attack you back.  Attack them again by pushing into them until the battle is resolved.
1. Create tab->Animated Sprites->Drag the monsterIdleAnimation into the scene.
2. Resize to suit.
3. Add the Entity behavior to the monster.
4. Change the description to “A nasty foe” – you won’t see this in game.
5. Change the info1 to “Prepare to meet thine doom!” – This will come up in the info window.
6. Change the info1 to “What a world. What a world!” – This will come up in the info window when you defeat the enemy.
7. Change the Type to 8 as per the functional specifications we looked at before ie ...

NPC 2 – an entity that will fight the player.

8. Change attack to 3, defence to 2 and health to 10.
9. 

10. In Scripting name it Monster1.
11. In Collisions set as shown below.


The reason Send Physics is switched on this time is so you don’t get caught inside the monster’s collision map and attack continuously.  This bumps him away so you need to bump him again next time to fight.
The event on the collision of the monster creates an attack sequence.  Here’s the code if you are curious.


Notice it only allows you to fight Monster1 or Monster2.  If you want to add more monsters you need to add them to the list here.  Next on line 268 it calls a function to handleCombat sending the id of the monster you are attacking.  Let’s look at that handleCombat function.

The circled markers are where I’ve “collapsed” the code to make this brief.  You will want to do this from time to time to work on other bits of code and make it easy to see all in one screen what is going on.
In lines 279 to 282 we get his and our stats.  Notice the call to AttackManager.  We used that before to buff the attack when the sword is picked up.
In lines 284 to 307 it compares the attack of the player against the defence of the enemy.  In that piece of code hidden away, if you are stronger than his defence the enemie’s health is reduced, checks to see if he’s dead and drop items if he is.  All this gets put to the info window.  If you aren’t strong enough it stops you from fighting and tells you to come back later.


In lines 313 to 317 your defence is extracted using DefenceManager which we will add soon.  The enemy’s attack is extracted as well.
In line 320 which is collapsed the enemy attacks you and reduces your health.
Finally in line 341-342 the results of the combat are shown in the info window.
12. From the static images drag out another T icon at the top of the scene.
13. Add the “Keep Track Of Defence” behavior to it.
14. In Scripting name it DefenceManager.
15. Run the game and push against the enemy.  Just tap.  You will see the attack in window.
16. 

17. The player does no damage.  It’s because your attack is the same as his defence, 2.  Go get the sword and try again.
18. The enemy is killed in one blow.  Notice it says info line 2 as well.
19. 

[bookmark: _Toc310968461]NPC2  - Enemy that Drops an item.
This kind of NPC or non-player character will attack the player but on death will drop items.  You attack by running into them.  They will attack you back.  Attack them again by pushing into them until the battle is resolved.
1. Create tab->Animated Sprites->Drag the monsterIdleAnimation into the scene.
2. Resize to suit.
3. Add the Entity behavior to the monster.
4. Change the description to “A more challenging villain” – you won’t see this in game.
5. Change the info1 to “You killed my father.  Prepare to die!” – This will come up in the info window.
6. Change the info1 to “You beat me. Inconceivable!” – This will come up in the info window when you defeat the enemy.
7. Change the Type to 8.
8. Change attack to 7, defence to 4 and health to 10.
9. 

10. Now drop down Drop and select InstantMana.  This is the monsters drop item.
11. In Scripting name it Monster2.
12. In Collisions set as shown below.


The event on the collision of the monster creates an attack sequence as before.  Check the previous monster for more details.  Send Physics is set on so you don’t continually attack him.
If you approach this new bad guy without a weapon your attack rating is too low and you will see this message.  Note he won’t mess around and still hits you for damage.  Go get the sword!


If you have sword your first attack looks like this.


Tap into him a few more times and eventually he dies, the info window updates with the results of the last strike, he says his dying words and a mana potion is dropped which you can pick up.


[bookmark: _Toc310968462]A talking NPC.
The talking NPC is a character that is of type 1.  We’ll use the Nun for this.
1. Drop in the nunIdleAnimation animated sprite to the scene.
2. Under the Edit-tab add the Entity behavior, set the description to “The helpful Nun”, info1 to “Our town is under attack.  Please help”.  Set type to 1.
3. 

4. In Scripting name her Nun1.
5. In Collisions set as follows.
6. 

7. Run the game and walk up to the Nun.  She gives you information and nothing more.
8. 

[bookmark: _Toc310968463]Challenge
Add the Soldier the same as the Nun only make him say “Bah –You save the town?  I doubt it.”
[bookmark: _Toc310968464]Creating a quest.
Note this is a bit long winded the first time you add the quest item and the give item.  Once setup you can use these again on other quests.  
1. Drop a copy of the item you want collected (use MonsterHead1 for this example) off the map where the T icons are.   This will allow the entity (the quest entity you are seeking) to know what is possible to be got.  Note it must be an animated sprite, not a static sprite.  
[image: ]
You already know how to make animated sprites because you’ve set up several characters by now.  A quest drop item without animation can be created by making an animation and just selecting one frame.  Then it can be used.
2. Add an Entity behavior to the monsterHead.  Set it to Type 3.  Set it’s description to “A monster head”.
3. Set the monsterHead scripting to MonsterHead1.  Set the collisions like this.
4. 

5. Create the armour object the player will receive – animated sprite again.  Drop that into the scene next to the monster head, add an Entity behavior to it and set up the defbuff to be 10.   [image: ]
6. Set the Scripting and Collision as shown.
[image: ]
7. Save the level and now you will have a definition in level1.t2d.  Go to Torsion and load this file below under “SimpleRPG/game/data/levels/level1.t2d” which looks like this.  When you make your own drops this is how to get the starter code.  By dropping an object in and setting up as before, then hitting SAVE on the level it makes this code for you.  This is exactly the code we need for handling drops – see below.


8. Still using Torsion, in the template ( the first bit of code) of the Entity.cs file located in “SimpleRPG\game\behaviors\”  insert the underlined piece of code – it won’t be there so 
add it. (copy and paste the next line if you want rather than typing it)

\nArmour10
If you wanted to add more to the list of objects to drop this is where you would do it.  The object to drop must be added (like we just added the armour) to the list to include a unique name for the item you want to drop as shown below.  


9. Scroll down to the function checkDrop() and add this code (copy and paste) at around line 387. 
if (%whatDropped $= “Armour10”)
{
	new t2dAnimatedSprite(Armour10) {
      animationName = "ArmourAnimation";
      canSaveDynamicFields = "1";
      Position = "-4.413 -56.931";
      size = "9.000 5.000";
      CollisionActiveSend = "1";
      CollisionPhysicsReceive = "0";
      CollisionCallback = "1";
         mountID = "74";
      _behavior0 = "Entity	desc	Armour	info1	Armour DEF + 10	Type	3	defbuff	10";
   }; 
}
This is how objects are generated during program execution.  It’s worth noting this for the future when you want to easily spawn objects.  Notice though, the red lines below were removed from the original code that was generated in level1.t2d.  If you were to make your own drops you would need to delete those lines also.



10. Now add the circled code and replace Position = and add the scenegraph line to look like this....


11. That uses the creature’s position to know where to drop the item. NOTE % x and %y are variables that store the creature’s position.
12. Your code should now look like this.
13. 

The effect of this is to drop the given item next to the quest giver when you have completed the quest.  You will be able to pick it up like any other item. RELOAD THE PROJECT!
14. Now drop in the wizardIdleAnimation – this is the quest giver.  Under the Edit tab add an Entity behavior to the Wizard.
15. Make the description “A wizard”. Change the info1 to explain the quest.  Change the info2 to give them a message on completion of the quest.  In this example I have selected the wizard and he says this as info1, “Greetings adventurer. Rock monsters are taking over.  You must fight them off. Bring me back a rock monster head and I'll give you armour.”  Then I’ve set the info2 to this as a message of congratulations, “Well done!  Take this Armour Def + 10, you earned it.”  Also set the type to 5 which says “5 = IsUsedItem”, meaning if you use an item on them (the quest item) they will say info2 and Give you something (only if set to give you something).  [image: ]
Just for an example (so don’t change anything right now) as a difference to this, you want the quest giver to just say something to lead you onto a new quest, then don’t set the give section to anything.
16. In this case however we want to give the player something in return for the quest item.  Move down to the bottom and change quest to MonsterHead1 and change give to the item Armour10.


17. Set up the scripting and collisions as shown.
18. 

19. Now you add a monster and set them to drop the MonsterHead1 on death as a questDrop.  See below.
[image: ]

20. Notice that the enemy also drops an InstantHealth too.  Enemies don’t have to drop either normal drop or quest drop items, or they can drop both.  The quest drop item will be added to the scene for you to pick up if you want.
21. Next open up Entity.cs in Torsion and scroll down to find the function dropQuest().  MonsterHead definition is already there.  If you want to add your own you need to copy and paste the code and update the underlined words.  It’s similar to what we did to drop the Armour.
[image: ]
Notice that the %whatDropped and t2dAnimatedSprite lines (the first 2) are exactly the same as the Scripting name for the sample object you dropped on the stage in the first place.  (see below the Scripting tab)
[image: ]
The animationName is the same as the one you called it when you made 1 frame animation of the monster head.
22. Lastly copy the monsterHead.png file in Session9 and copy and paste it into SimpleRPG\game\gui\ as shown.
[image: ]
23. Let’s see it in action now.  Approach the Wizard.  He gives you the quest.
[image: ]
24. After killing the Monster, it drops the head.  Go and get close to it.  It will allow you pick it up.  
[image: ]        [image: ]
25. Then clicking on take it’s added to your inventory.  Now you can take it back to the NPC who wants it.
[image: ]
26. When you take it back to wizard his info will change and he will drop the give item.   The head will also be removed from your inventory.
[image: ]
27. You can then pick it up and get any buffs attached to it.  Notice that the armour pic has to be in the same folder that the monsterHead was placed in as well.  (game/gui) to appear on the inventory screen.
[image: ]

If you tried to go back for the quest he now says this.



[bookmark: _Toc310968465]Adding a shop.
The shop keeper is fairly simply, in that it’s another entity, but this time he displays a large inventory screen on which are the items in his possession.  Clicking on any of these items will bring up the BUY/NO buttons, and if you have enough gold you will be able to add it to your inventory getting any benefits from the item as designated.
1. Import the shopBuilding.png, then shop.png, closeButton.png  and place the shopBuildingImageMap as shown.  Also in the SceneObject section under the Edit tab, make sure the shopBuilding Layer is 2 and if the trees are ontop of it, keep clicking bring to front until its ontop of the trees.  Make sure the shop isn’t too far up that screen otherwise when it shows the inventory it will be clipped at the top and you won’t be able to see all items.
2. [image: ]
3. Import the enemy1.png – he can be the shop owner.
4. Make a single animation of him using the following frames.
5. [image: ]
6. Drop him into the scene and add the Entity behaviour to him as shown.  Shop owners are type 7, an NPC that sells his inventory to you.
7. [image: ]
8. I’ve given him something to say as an intro in info1 “Greetings fortunate traveller. Would you like to buy something? “, and a farewell in info2, “Thank you for your business.  Please come again.”
9. Set up Scripting and collisions as shown below.  The shop owner’s class must be Shop1 – all other items will also have this class name so they are associated with that shop.
10. [image: ]
[bookmark: _Toc310968466]Preparing Shop Items.
You’ll need to make any static images you want to sell into Animated sprites of one cell.  I’ll show you how to add the Health and mana as the Armour is already done.
1. Under the Create tab double click on the heart and change it’s settings as shown and hit Save.
2. 

3. Double click on Mana and do the same.
4. 

5. Drop a text object into the scene and name it “Shop 1 Items” – make sure it’s above the scene.
6. 

7. Drag the Health across below it.
8. Click on the Edit tab and add the Entity behavior.  Set it up as shown and make sure it’s type is 4.
9. 

10. Scroll down to Scripting and name it specifically and set it’s class to Shop1 so it’s only sold in this shop.  
11. 

12. Go back to the create tab and add the Armour and Mana.  Here’s the settings.
13. 

14. 

15. 

16. 

[bookmark: _Toc310968467]Using the shop.
Run the game.  Walk up to the shop owner and his shop will appear.  Click on the objects to add them to your inventory.  Any buffs will be added.  Well done!  A simple RPG for you to get started with.




[bookmark: _Toc310968468]Session # 10   Scripting Masterclass.
If you recall I mentioned this session during the Pong class.  The purpose of this session is to fill in all the gaps, answer all the questions you have and up-skill you so you know how behaviors work and you can write your own for your final assignment.
[bookmark: _Toc310968469]What are behaviors?
Behaviors are text files that are written in a specific format so that Torque understands how you want to control your objects / graphics and sounds in the game.  You will use a program called Torsion which is a TorqueScript IDE.  TorqueScript is a very specific language that you write in for Torque products.  IDE stands for Integrated Development Editor.  This means it’s a very specific word editor that understands all the commands that make up TorqueScript.
Using Torsion set up a project to load all the scripts for Pong.  Use Appendix 2 to get you started.
1. Let’s have a look at the script.  Once Torsion is running open “ballControl.cs” under game/behaviors.
2. Let’s have a look at the first part.
[image: ]
3. Firstly notice the two lines I have underlined in red.  The friendlyName of “Ball Control” is the one you see in Torque as well.
[image: ]
4. The second line we are analysing (line 16) shows ballSpeed, “Speed when moving” and the number 10.  We see this in Torque as well.  If you hover your mouse over it in Torque (not Torsion) you will also see “Speed when moving” – that is the tooltip.
[image: ]
5. These lines of code are the TorqueScript words that create that behavior.  Why am I misspelling behaviour?  Because it’s an American product and they spell it this way.  
6. The ballSpeed is a name that remembers the value of 10.  This remembering process, and the fact that you can change the 10 to something else makes this word a “variable” – which means a name that can change its value.  Variables are the things in programming that make things happen.  If there weren’t variables, our game would remain static and unchanging – so it wouldn’t be interactive.
7. Scroll down while in Torsion and looking at the script and find this function called BallControl::onAddToScene(%this).  You will notice I have greyed out the code at the top and bottom.  This is for demonstration purposes and allows you to confirm where you should be in the script.
[image: ]
8. What does onAddToScene mean?  It’s an event driven system, so rather than checking every single time the game redraws itself, events wait until they are told to do something.  So in this case the event is told that it will happen when this object (the Ball) is added to the scene.  The scene is the current game grid we are working on.
9. The next two lines (21 and 22) set two internal variables to determine the movement of the ball.  In this case xMove is –tve so it will move to the left, and yMove is negative so it will travel up the screen.
10. Lines 24 and 25 are important as it tells the ball what to do when it hits the edges of the screen.  Setting it to NULL means we will tell it what to do.  The worldLimitCallback means it will respond to a function when this happens (which we will see soon).  
11. The last line 27 tells the ball to continually respond to a function we will see later call onUpdate which you can see greyed out below.  It’s a function that updates every 30 miiliseconds, so not as fast as the screen is drawn but fast enough to move things around.
Well that wasn’t too confusing was it?  It is your first step into scripting.  If you continue at this learning institute with Games Development you will learn more about scripting.  In this course you will become proficient at writing your own scripts to make your game after 10 sessions like this one.
[bookmark: _Toc310968470]Moving the ball with script.
Continuing on with the script and scroll down some more to find the onUpdate function.
[image: ]
1. Line 32 and 33 set the ball in motion.  Linear is a mathematical term for lines (or movement along axes).  
2. It moves along the X axis (left and right) at ballSpeed (the speed you set in Torque) 
3. It also moves along the Y axis (up and down) at ballSpeed.
4. Combining the two moves together makes the ball move at an angle.
[bookmark: _Toc310968471]Reacting to world limits.
When the ball reaches the world limit we have specified it will call this next function when we used the command at line 25.
[image: ]
Let’s look at it in more detail.
[image: ]
1. onWorldLimit is the callback we set at the onAddToScene function.  What is a callback?  A callback is a function that is only called when a particular thing happens.  In this case it’s when the ball touches the sides of the screen.  
2. onWorldLimit takes a few parameters in, in its function list.
3. [image: ]
4. The %this refers to “this” current object that is using this behavior.  Which is the ball.  There could be more than one object that uses this behavior, so we need to know which one were are talking about at any point in time.
5. The %limitMode refers to the type of limiting mechanism the object undergoes when it hits the world limit.  As we want to control this ourselves, it was just set to OFF.
6. The %limit is the actual word that comes back from the collision with the edge of the screen and comes as left,right, top or bottom.
7. When we have the %limit we then switch to which %limit it was.  In that case the ball hits the left side.
[image: ]
8. You can see the command switch$( %limit ) and below that that the command case “left”:  This means “based on what side the ball hit (left) do the following.  Then it goes on to add score for player 2.  We wont dig too much deeper into this, but at this point to sends ONE point to player 2’s score.  
9. Let’s review the rest of this function briefly.
[image: ]
10. We play the miss sound (lines 47 and 48), move the ball over to player 2’s bat (lines 50 and 51), make the ball move left (52) and make a random choice to make the ball bounce up the screen or down the screen (lines 54 to 61).  So when it goes off the left hand side, player 2 gets a point and serves.
11. Here’s the case for the ball going off right of screen.
[image: ]
12. If you read down now let’s all have a chance to decipher it.

The Lecturer can go through this with you at this point and it would be a good idea for the Lecturer to point at each line and for students to explain what is going on.
The last two cases hand the top and bottom of the screen, and simply flip the yMove to create the bounce effect.  It also makes a “pong” sound when this happens.
[image: ]
RIGHT!  Confused?  Scared?  Intimidated?  Thinking that this course is not for you?  Don’t be any of those things.  We did gloss over a lot of technical “blah blah” for all the games up til now because I think we’ve shown you enough to basically say making games can be as easy or complex as you want to make it with Torque2D.  By the end of the unit you will be able to choose if you want to get “down and dirty” with code, or stay “light and fluffy” and use pre-made behaviors to make your game.
[bookmark: _Toc310968472]Finding all objects in a scene.
This piece of code is useful if you want to find all the object you dropped into the scene of a particular class (type).
// list of all scene objects
%scene_objects = SceneGraph2d.getSceneObjectList();
// loop through found objects
for (%i = 0; %i < getWordCount(%scene_objects); %i++)
{
   %current_object = getWord(%scene_objects, %i);
   if (%current_object.class $= "MyClass") %current_object.MyFunction();
}
[bookmark: _Toc310968473]Creating Levels.
PuckaMan could do with a new level.  Let’s use TorqueScript to create the next level and introduce a new ghosts.
You essentially need to know two key functions:
%level = "game/data/levels/level2.t2d";  
// %level is a string containing the path to your level  
sceneWindow2D.loadLevel(%level);  
 
// This cleans everything up and closes the level  
sceneWindow2D.endLevel();  

You must always call sceneWindow2D.endLevel before you load a new level, unless you are doing something advanced.
To make a .t2d level be the first (default) level loaded when your application runs, look in the file commonConfig.xml, which is located under the 'common' folder. Edit the field labeled <DefaultScene>.

In your case, the field would look like this:
<DefaultScene>~/data/levels/Level1.t2d</DefaultScene>  
Alternatively, you can set this in projectFiles/game/scripts/game.cs startGame(%level) function:

Change this:
sceneWindow2D.loadLevel(%level);  

Into this:
sceneWindow2D.loadLevel("game/data/levels/Splash.t2d");  








[bookmark: _Toc310968474]Appendix 2 – Setting Up Torsion.
Torsion is a tool for editing code and debugging scripts.  We will now set it up to work with Balloon Pop.  By default when you make a new project in TGB a file called Game.Torsion is create which will do the following – but this is here to show you how to do it from scratch.
1. Find Torsion in the Programs Menu and run it.  Click on the button shown, or click on File->New->Project
2. 

3. Next you will see this screen.  Change the name to “BalloonPop” (all one word, no quotes) and then click on the BROWSE button on the next line.
4. 

5. Navigate to E:\T2DSemester1\Session1\Balloon Game as shown and click on Okay. [This finds the code for us to edit]
6. 

7. Next click on the Configurations tab at the top of the New Project screen and click on New.
8. 

9. Then click on the top section and give it the name Debug.  After that click on the Browse button circled below.
10. 

11. It should go to the same folder you specified before (if not, navigate there yourself).  Click on the BalloonGame executable as shown below and click on Open.  [This links the code we will be editing with the game executable – the engine that runs the code]
12. 

13. Back at the previous screen now it should look like this below.  Click on OK
14. 

15. Your Configurations tab should look like this below.  Click on OK.
16. 

17. Once you’ve clicked on Okay you will see it processing like this.  Eventually it will be ready to edit.
18. 
 
19. The key places you will work are marked.  I’ve hit the PLUS button next to them to expand the trees. 
20. 

21. I’ve also opened main.cs so you can see how the editor opens source code files.  This particular main.cs is required for the PuckaMan tutorial (session 4) Notice it’s the main.cs inside game folder not the one inline with project.t2dProj.
22. You can see I’ve circled the PLAY button at the top – this is how we run the game from source if not using the Torque game editor.
23. Game/behaviors is where we mainly work.
24. Common/gui is where on screen displays will be dropped when we work on the Role Playing Game.



[bookmark: _Toc310968475]Appendix 3 - Platformer Camera settings.


From 
http://tdn.garagegames.com/wiki/TGB/Tutorials/Platformer/Camera
Target: This should be the object that you want the camera to follow. For the MiniPlatformer, it's obviously the player which also has the script name of "player". The behavior as it is set up now lets you select t2dAnimatedSprites only. If you want you can change the list of selectable objects by changing the t2dAnimatedSprite in this line:
   %template.addBehaviorField(target, "The object that the camera will track", object, "", t2dAnimatedSprite);

to either t2dStaticSprite or t2dSceneObject, for example.

Track Force: This value determines with how much lag the camera follows the player's movements. 0 is rigid (player and camera move in parallel), otherwise increasingly higher values also decrease the amount of lag seen.

View Limit: This check box turns on or off the camera's view limit. Similar to an object's world limit, the view limit traps the camera within a certain area of your level. This can be helpful to make sure the player doesn't see blank areas outside the tile layers or background sprites. To set this up, hover the mouse over the scene object and click on the far right tooltip icon for changing the object's world limits (Figure 3.4). Have the world limit box cover the entire area of your level (Figure 3.5). Hit enter to leave the world limit setup mode and now you can have the view limit box checked.
Track Height: If you want the camera to follow player movements in the Y direction, check this box. Otherwise it will only follow the player in the X (horizontal) direction. If this box is NOT checked, the position of the scene object this behavior is attached to does matter in relation to the player.

Face Player: This box is used in combination with the next field for setting the X directional offset. If you want the camera to always be 10 units in front of the player, set the xOffset value to 10 and check the facePlayer box. If this box is not checked and you have an offset, in one direction the camera will be ahead of the player and if the player moves in the opposite direction it will stay behind the player.

X Offset, Y Offset: The values you put in these fields will alter the position of the camera in relation to the player. 0, 0 will always keep the player in the center of the screen. The Y Offset value only works if you have the trackHeight box checked.

Auto Scroll: Like certain levels in the Super Mario Bros. games, checking this box will have the camera move at a constant speed defined by the scrollSpeed field and does not follow the player. Currently auto scrolling is only enabled for the X direction.

Trap Object: Traps the object defined in the target field within the current area of the camera.

Scroll Speed: How fast the camera scrolls in Auto Scroll mode is defined by this field.
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[bookmark: _Toc310968477]Description: 


This is a national unit, the description of which is:

	This unit describes the performance outcomes, skills and knowledge required to use an authoring tool to produce discrete interactive sequences.

This unit will introduce you to authoring 2D games using a program called Torque2D.  No previous knowledge of authoring or creating games is required. In the first part you concentrate on learning the software, how to make a game using the latest version of Torque 2D v1.7.5, released in July 2010. In the second part of the unit you concentrate on designing and creating an original game. Because the game industry works in teams, you will work with a partner in the second part.


Duration: 			50 hours (two and half hours a week for one semester)


Prerequisites: 		None


Resources

You will be supplied with a printed copy of this student workbook. If you lose it, you will have to print out another for yourself from the softcopy in the network folder. The images and sound files mentioned in the workbook are available on the student network


[bookmark: _Toc310968478]Elements of Competency:


· Plan use of authoring tool
· Prepare to use authoring tool
· Produce interactive sequences
· Check functionality of interactive sequence


[bookmark: _Toc310968479]Individual Learning and Assessment Needs

Central Institute of Technology recognises that students have different learning styles and needs. Please let your lecturer know if there is anything that may have an effect on your learning.


[bookmark: _Toc310968480]ASSESSMENT SUMMARY

	DUE 
	ASSESSMENT 

	
	

	To obtain an overall pass mark, you must successfully pass in each of the following. A percentage has been given to indicate the relative weighting of each:

	Session 6
	Analysis of an existing game.      15%

	Session 10
	Completion of the games developed in the workshops.     10%

	Session 12
	Design documentation for a new game, in collaboration with a partner.     25%

	Session 17
	A complete, original game.      50%




[bookmark: _Toc310968481]Support Materials

There are many books on game design in the Central Institute of Technology Library, including:

Chris Crawford (2003), Chris Crawford on Game Design, New Riders, Indiana.

Jason Darby (3rd edition, 2008), Awesome Game Creation: No Programming Required, Thomson Learning, Boston.

Jacob Hapgood and Mark Overmars (2006), The Game Maker’s Apprentice: Game Development for Beginners, Apress, New York. (On closed reserve in library)

Jeannie Novak (2008), Game Development Essentials: Game Project Management, Thomson Delmar, New York.

Nanu Swamy and Naveena Swamy (2006), Basic Game Design and Creation for Fun and Learning, Charles River Media, Massachusetts.

Online

Garage Games, the home of Torque            http://www.garagegames.com/


[bookmark: _Toc310968482]Class Schedule
There are three Public Holidays on a Monday during Semester One and one on a Friday.
This will effect which week some classes cover a topic. Your lecturer will advise you.

	Session
	Topic
	Assessment

	1
	Introduction to the unit and 2D game design using Torque 2D and Torsion.  Balloon Pop
	

	2
	Recreating classic video games: Pong
	

	3
	Recreating classic video games: Space Attackers
Workshop using Aesprite
	

	4
	Using code and scripting – Astar path finding introduction to Torsion
Recreating classic video games: PuckaMan 
	

	5
	Recreating classic video games: Super EpicMan
	

	6
	Presentation to class of your chosen game and your analysis of it.
	Assessment Item 1

	7
	3d and parallax scrolling using Scrollers and Torquescript.
	

	8
	Parallel effects and scripting in an RPG
	

	[bookmark: _Toc310968483]Break
	No Classes
	

	9
	Scripting Masterclass
	

	10
	Demonstration to lecturer of all eight completed games
	Assessment Item 2

	12
	Appointment with partner(s) and lecturer 

	Assessment Item 3

	13
	No class, private work on Assessment 4
	

	14
	No class, private work on Assessment 4
	

	15
	No class, private work on Assessment 4
	

	16
	Appointment with partner(s) and lecturer to display prototype of Assessment 4
	

	17
	Presentation to class, hand in files on CD
	Assessment Item 4

	18
	Resubmission if required
	






[bookmark: _Toc310968484]Results and appeals. 
Please refer to the Central Institute of Technology website for information about the assessment process. The information can be found at www.centraltafe.wa.edu.au. The path is; home – current students- your studies – assessment.


[bookmark: _Toc310968485]Assessment Item 1    Due Week Six


Your game review will consist of two to three typed and spell checked pages which you should hand to the lecturer attached to a New Media Assessment Cover Sheet. You should cover these issues:

· Title, creator, year, intended audience, genre
· Description of the game (add some pictures). Do not make this section too long, it must be no more than one third of the review
· Role of the story (if any)
· Quality and appropriateness of graphics, sounds, and music
· Features versus appearance
· What is essential in the game and what is not
· Game play 
· forms of decision making
· balance between the different features
· motivation to start and keep playing
· variation, long-lasting appeal
· What could have been left out without hurting the game
· What should have been added to improve the game

Your review should be written from a game designer’s perspective not just from a game player’s.

Your game should be 2D rather than 3D and must have been made using Game Maker. In the network drive there is a Word document of links to websites with such games.

In class you will briefly show the game and summarise (not read) your review.


[bookmark: _Toc310968486]Assessment Item 3    Due Week Twelve


Create with your partner(s) a concept document (sometimes called the pitch document). The purpose of the document is to sell the idea so that development will be authorised/funded. 

In one or two sentences state the basic idea of your game. Imagine this as a statement that could be used in the packaging of the game to sell it. 

Say who the intended players of the game are. Make sure you give the target age and any other relevant demographic or geographic information. Say which genre (such as action, puzzle, role playing) your game fits into (players tend to buy and play games in their favourite genres).

Describe the characters and the game play. The game must be created in Game Maker. You will have to work within its limitations but also be able to use its capabilities.

List the features (such as enemies and power-ups), with information on what their function is and where and how they appear in the game. State how rewards and penalties will be handled.

Describe the user interface.
Include a description of the various levels in the game.

List music and sound effects needed (you will not be expected to create original audio).

In a page give a timeline for the production as a three column table, with detail on who is responsible for what and when by.

All this should be done within five or six typed pages.

Attach concept drawings and sketches of characters and scenes (you will not be expected to create original graphics). 

Note that the final game seldom matches exactly the design document. You can and should amend your design as new ideas or circumstances dictate.
[bookmark: _Toc310968487]Assessment Item 4    Due Week Seventeen

Warning: In the first part of the unit you followed detailed instructions to make games. This will have led you to underestimate how long it takes to make a game.
It will take you much longer than you think to make a game and you will often hit problems when you try to make what you have imagined. Allow plenty of time.
 
You will present your game to the class and give it to the lecturer on a CD, which contains the Build of the game including the source. The lecturer will load the built application into the network drive so everyone can play it later.
To build your game click on the File mention and select Build Project...
[image: ]
Next specify the game name and folder and then TICK include Script Source.  Then click on build.  You will want to copy the folder that is the same name as your final game as circled.  DONT name the game the same as the folder your project already resides in.
[image: ]

During your presentation you should state what changed during development, where you altered your design, and what were the areas of difficulty you experienced.

Your game should be complete and fun to play. It should have an intro (e.g. starting screen), help, credits and at least two levels of progressive difficulty. It does not have to be a very long game though. 
Please add a cheat using the N key to skip through the levels for testing purposes if you have multiple levels.
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By 4= 5;

new t2dAnimatedSprite (Armourl0) {
animationName = "ArmourAnimation”;
Position = x SEC %y
scenegraph = Swno.scenegraph;
size = "9.000 5.000
CollisionhctiveSend = "im
CollisionPhysicsReceive = "07;
CollisionCallback = "1".
_benavior0 = "Entity desc Armour

infol Armour DEF + 10

Type

3 defpurs 107;
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// checks to see what vas dropped and place it by the ovner
if (suhatDropped §= "HonsterHeadir)
¢

this.drop = nev tzdinimatedSprite (HonsterHeadl)

¢ E—

animationName = "monsterieadinimation”:
CollisionictiveSend = "1
CollisionPhysicsReceive = "07;
CollisionCallback = "17;

Position = %x SPC Gy:

size = "4.125 4.7507;

scenegraph = *uho.scenegraph;

_behaviorn
i

"Entity desc A monster head Type 3"
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// Create this behavior only if it does not already exist
if (1isObject (BallControl)

7/ Create this hehavior from the blank BehaviorTemplate
“template = new BehaviorTemplate (BallControl]

// friendlyName will be vhat is displaved in the editor
// behaviorType organize this behavior in the editor

// description briefly explains vhat this behavior does
“template.friendlyName = "Ball Control
“template.behaviorType = "Objects’;
“template.description = "Hoves ball around screen”;

// verticalSpeed determines how quickly the cloud moves up and down
// horizontalSpeed determines how gquickly teh cloud moves left and right
“template.addBehaviorField (pallSpeed, "Speed when moving”, float, 10.0)
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19 )
20 | ¢

21 xlove = -1;

22 Lylove = -1;

23

24 -ouner.vorldLinitlode = "NULL";
25 -ouner . wor laLimitCal lback ;
26

27 -ouner . enableUpdatecal back (] ;

28 by
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27 | sthis.ouner.ensbleUpdateCallvack():
28 Ly

25

30 5 function BallCentrol:
a1 [«

32 | schis.owner.setlinearVelocityX( cthis.xllove © sthis.ballSpeed) ;
33 | tchis.owner.setlinearVelocity¥( this.yllove © *this.ballSpeed) ;
as by

as

36 Ziunc\:)ﬂn Ballcontra

sonUpdate ( sthis )

onWorldlimit( this, %limitHode, %limit)
37 [ ¢«

38 switch$ (% limit)
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25

sthis.owner.worldLimitCallback = true;
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function BallContral

f

switch$ (s limit)

¢

case "lert™:
7/ player 2

onWorldLimit( this, *limitHode, *limit)

// add to score

“scoreBehav
“scoreBehav

= Ball.getBehavior ("KeepTrackScore"} ;
.addToscoreplayerz ( 1 ):

7/ play miss sound

“audioBehav
saudioBehav

AudicHandler . getBehavior {"AudicPlayer”) ;
.playSE(Miss", 1.0

7/ launch ball from player 2 bat

“this.owner
“this.owner
“this.xliove
// randomly

.setPositionX (Playerz.getPositionX() - Ball.getVideh(]
.setPositiony (Playerz.getPosition (]} ;

-1

bounce up or down

):




image478.png
36 G function BallControl::onVorldlimit( sthis, *limitlode, *limit)
.
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(%limit)

"left":
// player 2 scores

// add to score
sscoreBehav = Ball.getBehavior ("KeepTrackScore");
%scoreBehav.addToScorePlayer2 ( 1 )
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7"

%scoreBehav

add to score

/4 player 2 scores

// play miss sound

“audioBehav

Ball.getBehavior (
“scoreBehav. addToScorePlayer2 |

1

7/ launch ball from player 2 bat

“this.ouner.setPositionX (Player?.getPositionX ()

0g

hudicHandler.getBehavior ("AudicPlayer”)
“audioBehav. pLaysE ("miss", 1.0)

- Ball.getVideh()

“this.ouner.setPositionY (Playerz.getPositiont ()}
tthis.xlove =- 1

// randomly bounce up or down
(getRandam(0, 1)

if
¢

)

“this. ylove

else

f

sthis.ylove =

1

1

1

):




image481.png
64
65
66
67
68
69
70
71
72
73
7a
75
760
77
7
7
a0
a1
£
83

case "right':

// player 1 scores
“this.xlove = —ithis.xMove;

7"

“scoreBehav

add to score

10

Ball.getBehavior ("KeepTrackScore") ;
%scoreBehav. addToScorePlayerl |

“audioBehav = AudicHandler.getBehavior ["AudicPlayer”) ;

“audioBehav. pLaysE ("miss", 1.0)

7/ launch ball from player 1 bat

“this.ouner.setPositionX (Playerl.getPositionX()

+ Ball.getVideh()

“this.ouner.setPositionY (Playerl.getPositiont ()}
“this.xlove = 1;

// randomly bounce up or down

if
¢

)

(getRandam(0, 1)

“this. ylove

else

f

sthis.ylove =

1

1

):
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case "top”:
7/ pounce
“this.ylove = —:this.ylove;
// make a pong scund
“audioBehav = AudicHandler.getBehavior ["AudicPlayer”);
“audioBehav. playsE ("pong”, 1.0)
case "hottom:
// pounce
“this.ylove = —:this.ylove;
// make a pong scund
“audioBehav = AudicHandler.getBehavior ["AudicPlayer”);
“audioBehav.playSE ("pong”, 1.0) ;
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Typical the folder where the executable and entry script are located.
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The game executable for ths coniguation.
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Argumerts

Debugging

Enable Precomple
Enable setiocPaths (]
OneClick Debugging
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File Edit View Project Debug Tools Window
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< foom o & s

| project| coce croveer |
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B proectodbrej
% Consolelog

((Giobals)
@ BalloonPop e
& ommer> 2 // Torque Game Builder
T 3 /1 Copgsight (©) Garagetames.com, Inc.
s
s
) preferences | 7 // initializeProject
2] commonConfigxml 8 // Perform game initialization here.
9 //-
10 @ function initializeProject()
= ) 1t
L audioBehavior.cs 12 // Load up the in game gui.
| kespTraciscores 13 | exec("~/gui/mainScreen.quin);
[ mouseDownRemove.cs s
[ mouseDownRespavin.cs 15 | // Exec game scripes.
[ moveOnscreen.cs 16 | exec("./gamescriprs/game.cs”
7] moveOnScreenRandom.cs 17
[ movelpScreen.cs 18| // This is where the game starca. Right
moveUpScreenFadeAway.cs 15 | 7/ want to expand this to load up a sple
= P e 20 // specific needs of your game. Most 1i}
21 /"

is where starcGame should be called f_

D

[output | et [Clsoc [ Reuts [sedons |

woemos | & B | & B

D

EAT2DSemesterl\Sessiont \BalloonGame\ game\main.cs.

Ln1 Coll  Off0 Chra7.

N
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Keep Track Of Score

Manages the score in-game.
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